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This document will guide you through setting up the Konica-Minolta for use with a
turntable.

Hint: You can click on any image to see a larger version.

TRIPOD & MOUNT

1.  Setup the scanner tripod.  The tripod doesn’t have to be completely level but you want it to be stable so
some degree of leveling is required.

2.   Prep the scanner mount by pulling the black lever out, pushing up the gold pin, and then releasing the
lever.  This widens the slot where the scanner mount rests.  

When done correctly, the lever will continue to stick out.

http://gmv.cast.uark.edu/wp-content/uploads/2013/03/KM_setup2.jpg


CONNECT SCANNER

3.  Place the scanner on the tripod until it locks into place (you will hear a ‘click’ sound when the mount has
locked).  Once the scanner has been mounted, ensure that your setup is stable.

4.  Remove the power cable and gray  SCSI cable with the PCMCIA card adapter from the small black case. 
Plug the scanner power cable in and connect the SCSI cable.  DO NOT TURN THE SCANNER ON.
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5.  Remove the card insert from the PCMCIA slot on the laptop and plug the PCMCIA card into the laptop.

SETUP TURNTABLE

6.  Remove the turntable, black power box, and all cables from the black case.  Set the two, black and
white calibration charts to the side for now.  Place the turntable approximately 1 meter (or slightly less)
from the scanner with the corded end facing towards the front i.e. towards the scanner. The suggested
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scan range for the tele and mid lenses is .6 to 1 meter.  When you begin scanning, the distance parameter
will be displayed in the scan window.  We generally suggest to keep the distance in the range of 700-800
mm to avoid data loss that can occur when an object is either too close or too far from the scanner.

7.  Plug the gray cable from turntable into the black power box; also plug the power cable into the black
power box. Next, take the blue serial cable and plug the green end (with 4 prongs) into the COM1 port on
the black box.  NOTE:  Theprongs on the green end are directional and will face down.

 

 

CONNECT LAPTOP

8.  Next, take the other end of the serial cable and plug it into the serial connection on the laptop.  To
work with a laptop, you will probably have to remove the black case around the plug end using a small
screwdriver.

http://gmv.cast.uark.edu/wp-content/uploads/2013/03/KM_setup5.jpg


 

POWER UP SCANNER

9.  Once everything has been plugged in and you have the desired lens in place (see the Changing
Lenses section in the final slides of this post if you need to change the scanner lens). Next power on the
scanner. It will take a minute to load, when it is complete, it will display the following message on screen
“Please open laser barrier and press any key.”

http://gmv.cast.uark.edu/wp-content/uploads/2013/03/KM_setup6.jpg


 

10.  Next, pull the large round cap off of the front of the scanner (bottom) and remove the lens cap (top),
and then press any button on the back of the scanner to continue.
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OPEN POLYWORKS

11.  Next power on the laptop and log on.  Note:  It is important to power the scanner first and
then the laptop so the connection is established.

12.  Once everything has been turned on, open Polyworks on the laptop.  Once the Polyworks Workspace
Manager opens, open the IMAlign Module.  Next, go to Scanners menu, and select Minolta – VIVID 9i.  In
the window that comes up,  you should see a live camera view from the scanner (connection successful –
hooray.)  You are now ready to continue to the Konica-Minota Vivid 9i – Scan Settings post.
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VIVID 9i LENSES

Changing the Lenses on the VIVID 9i

The VIVID 9i comes with a set of three interchangeable lenses: tele, middle, and wide.  The scanner’s
camera array is fixed 640X480 pixels.  Each lens offers a different field of view with the tele being the
smallest.  The FOV for each lens is provided below.

The tele lens offers the best resolution and is ideal for scanning objects smaller than a baseball or larger
objects with a higher resolution.  The mid lens works well for objects that are basketball size and was the
lens predominantly used for scanning pottery vessels in the Virtual Hampson Museum project.  CAST
researchers generally do not recommend use of the wide angle lens.

 CHANGING LENSES I
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A.  To change the lens on the VIVID 9i, first make sure the scanner is turned off.

B.  Next remove the lens that you wish to use from the lens box and its plastic bag.

C.  Next remove the lens protector and unscrew the lens that is currently on the scanner. 
IMMEDIATELY place the lens cap (located on the lens box) on the back of the lens.

NOTE: Every lens should always have 2 lens caps (one of the front and back of the lens) when the lens
is not in use or is being stored.
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 CHANGING LENSES II

D.  Remove the back lens cap from the desired lens and screw the new lens into the scanner by first
lining up the red dots found on both the lens and the scanner.

E. Replace the black lens protector on the scanner.  Replace both lens caps on the newly removed lens,
place in a plastic bag, and store in the lens box.

F.  You are ready to begin scanning.  Power on the scanner and continue with Step 9 on the ‘Power up
Scanner’ Slide  above.

CONTINUE TO…

Continue to Konica-Minota Vivid 9i – Scan Settings.

 

]]> http://gmv.cast.uark.edu/scanning/hardware/konica-minolta-vivid-9i/checklist-konica-minolta-vivid-
9i/konica-minota-vivid-9i-setup/feed/ 0 http://gmv.cast.uark.edu/scanning/airborne-laser-scanning/als-and-
archaeology/ http://gmv.cast.uark.edu/scanning/airborne-laser-scanning/als-and-archaeology/#comments
Tue, 15 Jan 2013 21:08:36 +0000 Rachel http://gmv.cast.uark.edu/?p=11960

ALS and Archaeology.

http://gmv.cast.uark.edu/wp-content/uploads/2013/03/KM_setup12.jpg
http://gmv.cast.uark.edu/uncategorized/konica-minota-vivid-9i-scan-settings/


Hillshaded lidar terrain model revealing
(undated) remains of field systems now
located within the Chailluz Forest, France.
ALS Data credit: Region de Franche-Comté
/ MSHE Ledoux

Airborne Laser Scanning (ALS), or lidar, has been described as one of the most important innovations in
data collection and interpretation for archaeology in recent years (Bewley et al. 2005). Certainly, ALS has
become an important part of the archaeologists toolkit. First, and perhaps foremost, it has been employed
in mapping and prospection surveys in woodland, scrub and open ground. Critically, it may provide the only
means of survey -and consequently the collection of archaeological information- in difficult to access areas.
Beyond prospection, ALS is now used in research and cultural heritage managements tasks ranging from
assessments of the impact of hydrology on site locations, to the calculation of inter-visibility of a network of
sites, to the analysis of landforms to create inputs for predictive modeling. The popularity of ALS for
studying forested areas, floodplains and rural areas in general has renewed interest in the topic of
topographic survey, and further spurred integration with digital technologies and applications. The growing
use of ALS in archaeology has raised a number of issues, briefly outlined here.

Basic Processing and Classification.

Points incorrectly classified as low
vegetation (dark green) which should be
terrain (orange).

Archaeological applications demand high quality processing and classification of the ALS data. Because
many buried or surface archaeological features are both small scale (in xy) and low relief (in elevation) and
are often in woodlands or other heavily vegetated areas, good alignment within the point cloud is necessary
to minimize noise, and a good classification is necessary to distinguish between low vegetation and low
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relief terrain features which may represent archaeological remains.

Visualization.

Processing and visualization clearly affect interpretations. There are many possibilities to generate new
models and visualizations, and a concurrent possibility of continually tweaking parameters in the hope of
‘improving’ the model. Archaeologists undertaking a project using visualizations should pose two questions.
First, how much information can be retrieved, and with how much effort? Crutchley (Cowley and Opitz
2013) observes that if one model gives 90% of the nominal ‘total’ information, then the decision not to
chase the other 10% may be a practical one. This pragmatic approach avoids the dangers of loosing sight
of survey objectives in an endless round of data processing and manipulation. However, assessing the
cost/benefit and deciding where to stop data manipulation, because a certain approach gives enough
information for the task at hand, is not always obvious.

Sky View Factor visualization of karstic
terrain. Schematics image credit: Zaksek et
al., 2011

Popular 2D visualizations of bare earth DTMs in archaeology include:

-Classic Hillshades
-Multi-Directional Hillshades
-Slope Maps
-Sky View Factor
-PCA of multiple Hillshades

Simultaneous viewing of the point cloud, in profile or as a 3D model, alongside the shaded terrain model is
common practice. The combined information from multiple views of the same data helps interpreters to
understand if a small bump is likely to be a potentially archaeological mound, or built up soil around the
base of a particularly large tree, not fully removed by the filtering process.

Metadata about Visualizations.

Providing detailed information on how a model and visualization was created is essential for others to
understand and evaluate the end product and interpretation. Kokalj et al. (in Cowley and Opitz, 2013)
recommend metadata about processing and visualizations as follows:

-data scanning: scanner type, scanning density, density of a combined dataset, scanning date;
-data processing: method(s) used, parameter settings, description of the processing goal (e.g.
producing a terrain model, removing just the vegetation), elevation model resolution;
-visualization: method(s) used, parameter settings (e.g. hillshading (Sun elevation and azimuth), LRM
(method, distance), SVF (distance, directions);
-interpretation process: reliability of the results (qualitative if quantitative evaluation is not possible,
e.g. low to high, description of each class is recommended).

http://gmv.cast.uark.edu/wp-content/uploads/2013/01/ALS_visualization.jpg


Analyses Using lidar DTMs.

The detailed terrain models produced from ALS data are used in archaeological research and cultural
resource management as inputs for a number of analyses. These include:

-Visibility Studies
-Predictive Modeling
-Least Cost Path and Cost Surface Modeling
-Erosion Assessments

Viewsheds calculated based on the lidar
DTM of the Boyne Valley, as observed from
Newgrange. Image credit: Opitz and Davis,
AARG 2012

External Resources.

The ArchaeoLandscapes Project is an EU based project promoting the use of remote sensing and surveying
technologies in archaeology. Their website is an excellent resource for both general information and case
studies about the use of ALS in archaeology.
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The English Heritage Guide to Airborne Laser Scanning provides good information on the use of ALS in the
context of a national cultural heritage management organization.
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The Gabii Project is an international archaeological project, directed by Nicola Terrenato of the University of
Michigan. The Gabii Project began in 2007, seeking to study the ancient Latin city of Gabii through
excavation and survey. Gabii, located in central Italy, was a neighbor of and rival to Rome, and flourished
during in the first millennium BC.

The excavations at Gabii are uncovering extensive and complex remains within the city’s urban core.
Convergent photogrammetry is essential to the project’s recording strategy. At Gabii, this technique is used
to document features with complex geometries or large numbers of inclusions, including walls, pavements,
rubble collapse, and architectural elements. These types of features can be quite time-consuming to
document thoroughly by hand or using conventional surveying in the field. The 3D models collected in the
field are georeferenced. They are subsequently simplified for incorporation into the project’s GIS, and
compiled into models for distribution online using Unity3D.

You can see a sample model in the Unity3D interface here. You will need to download and install the free
Unity webplayer to view the model.

Map Sat Ter
Loading...
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View Gabii Project in a larger map
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Detail from the model of the K11
kerbstone, showing decorative carving on
the rock surface.

The archaeological complex at Knowth, located in the Brú na Bóinne World Heritage Site, consists of a
central mound surrounded by 18 smaller, satellite mounds. These monuments incorporate a large collection
of megalithic art, primarily in the form of decorated stones lining the mounds’ internal passages and
surrounding their external bases. The megalithic art found at this site constitutes an important collection, as
the Knowth site contains a third of the of megalithic art in all Western Europe. The kerbstones surrounding
the main mound at Knowth, while protected in winter, sit in the open air for part of the year, and are
consequently exposed to weather and subject to erosion. The Researchers at CAST, in collaboration with
UCD Archaeologists and Meath County Council, documented the 127 kerbstones surrounding the central
mound at Knowth over the course of two days using close range convergent photogrammetry. This pilot
project aims to demonstrate the validity of photogrammetry as the basis for monitoring the state of the
kerbstones and to add to the public presentation of the site, incorporating the models into broader three
dimensional recording and documentation efforts currently being carried out at Knowth and in the Brú na
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Bóinne, including campaigns of terrestrial laserscanning and aerial lidar survey.

The k15 kerbstone is available here as a sample dataset. You can download the 3D pdf (low res) or the DAE
file (high res).

Photogrammetry data from this project was processed using PhotoScan Pro.

Photoscan Pro processing of the model for
the K15 kerbstone.

Map Sat Ter
Loading...

View Knowth TLS and Photogrammetry in a larger map
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What is OpenCTM?

OpenCTM is a new open source file format for 3D objects that boasts impressive compression capabilities.
Using OpenCTM, a 90 megabyte model compresses to 9 megabytes. This makes OpenCTM ideal for web
delivery. Although there are still many kinks to iron out, the following tutorial explains how to create an
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OpenCTM from a 3D model and place it on the web using WebGL and JavaScript.

Demo files

The web viewing script is here as a zip file. You will need a functional web server to place the files in. The
script loads the model through an XMLHttpRequest, which requires the web page be loaded from an http
server. The model won’t load if the web page is opened from the hard drive.

OpenCTM and Meshlab

The easiest way to convert a model to OpenCTM is to use the open source 3D modelling program MeshLab.
Once you have imported the mode into MeshLab, we will perform a number of steps to prepare the model
for web delivery.

Texture to Vertex Color

1.The current JavaScript doesn’t support textures, but uses vertex color instead. To convert textures to
vertex color, in MeshLab go to Filter > Texture to Vertex Color (between 2 meshes)
2.Make sure the Source Mesh and Target Mesh are the same. Then press Apply.
3.Toggle the textures off to check if the conversion was successful. Render > Render Mode > Texture. You
can also find the icon in the main toolbar.
4.If the texture still appears to be shown on the model after toggling the textures off, you know that the
Texture to Vertex color was successful.

meshlab
texture
icon

Cleaning the Mesh

The web viewer can be temperamental about mesh geometry. If there are too many holes or rough edges,
the script could cause the browser to crash or hang up indefinitely. The solution is to perform a number of
steps that will clean the geometry enough for the web viewer script to be satisfied.

Preliminary Cleaning

1. Filters > Cleaning and Repairing > Close Merged Vertices

2. Filters > Cleaning and Repairing > Remove Duplicated Face

3. Filters > Cleaning and Repairing > Remove Duplicated Vertices

4. Remove Face from Non Manif Edges

http://gmv.cast.uark.edu/wp-content/uploads/2012/08/OpenCTM-Workflow.zip
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These steps are the preliminary cleaning methods before export. After you complete these steps, export the
mesh and try to load it in the browser. If the model loads, all is well. If the browser hangs up or crashes,
we’ll have to perform additional cleaning steps

Manual Cleaning

For manual cleaning, we need to cut any section of the mesh that appears questionable. Typically this will
be near and on the edges of the mesh. The screenshot below gives a good impression of what to look for.

1. Rotate the model so that the section in question is horizontal.

Manual Cleaning 2

2. Click Edit > Select Faces in a Rectangular Region
3. Drag and select the area in question

Manual Cleaning 3

4. Click Filter > Selection > Delete Selected Face and Vertices
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5. Repeat for other questionable sections of the mesh
6. Export

Exporting

Whenever you want to give the model a test run, you’ll export it out as a OpenCtm file.

1. Go to File > Export Mesh as
2. In the Files of type below, select “OpenCTM compressed file (*.ctm)” from the dropdown men
If OpenCTM is not an available option for export, you may need a more recent version of Meshlab
3. Save as…

Be sure you save the model on the web server where the javascript file is located.

View Your Results

To see the model in the web viewer, we’ll need to open up the demo.html file and change one line of code.

1. Open the demo.html file in your favorite editor.

2. On line 72, you will find in quotes the string “changeME.ctm”

3. Change this to the name of the model. If you named the model “myCoolModel.ctm”, you want to add
“myCoolModel.ctm” with quotes. If you placed the model in a folder, be sure to add the directory as well,
like this “/myModels/myCoolModel.ctm.”

4. Open the website. If you placed it on a local webserver, the address will be something like
“http://localhost/demo.html.” if you placed the web scripts and model on a different server, use the name
of the server.

NB: Once you have exported as OpenCTM, you can also export out as OBJ for a Unity model as well.
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This series of posts will teach you how to navigate in Unity and to create a basic virtual
museum. 
Hint: You can click on any image to see a larger version.
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Get Some Scripts

This tutorial will describe a basic setup for adding simple interactions to the walkable demo we created in
the previous tutorial. To do this, you’ll use several scripts contained in the package you can download here.

Have Unity open with the project used in the last tutorial

Download it and double click on it with Unity open.

Import all the scripts.

Script Documentation

The scripts are documented, if you would like to view them and learn more. You can find additional
resources concerning the Scripting API in Unity at the Unity Script Reference page.

Unity Scripting Languages

Unity allows you to create in scripts in three languages: JavaScript, Boo, and C#.

JavaScript is well known for web scripting and is part of the same standard as Flash’s ActionScript. Unity’s
JavaScript has notable differences, but it provides the easiest way to interface with GameObjects.

C# is native to .NET and the Mono project, which Unity is based on. It provides many advance options that
JavaScript lacks.

Boo is a lesser known language. Not many people code in Boo, but it has many similarities to Python.

The Museum Scripts

The package contains three scripts:

ArtifactInformation.js : This is a basic data repository script. When you add it to a GameObject, you’ll be
able to enter basic information about the object in the inspector that can be shown when the user clicks on
the object. Place it on each artifact you wish to interact with.
We could obtain the information in a number of ways, MySQL database, XML, etc. For this demo, we are
mainly worried with what to do with the data once we receive it.

ObjectRotator.js : This script allows us to rotate the object when we click on it. It also needs to be
attached to each object you want to interact with.

ArtifactViewer.js : This script is attached to the FPC’s main camera. This script will detect if we are looking
at an object when we left mouse click. If an object is in front, it will deactivate the FPC, show the
information of the object and activate object rotate mode. It must go on the Main Camera inside the First
Person Controller.

Setup a Sphere Collider

We need to perform several steps to prepare the script for activation. I assume you have placed an artifact
on one of the pedestals in the museum. Be sure to make the scale factor of .005. Otherwise, hilarity will
ensue. Leave the Generate Colliders box unchecked.

https://dl.dropbox.com/u/22781413/museumdemo/MuseumScripts.unitypackage
http://unity3d.com/support/documentation/ScriptReference/index.html


Add a Sphere Collider

1. With the object selected, go to Components > Physics > Sphere Collider

This allows us to detect if we are in front of the object.

Add New “Artifact” Tag

1 .With the object selected, go to the top of the Inspector and click the drop down menu next to Tag and
click Add Tag.

2. Open the Tag hierarchy and in Element 3, add the text “Artifact”.

3. Go back to the object’s properties in the Inspector, and make sure the newly created “Artifact” tag
appears in the Tag drop down menu.

4. Do this for all artifacts you wish to interact with.

5. Select the FPC and assign the “Player” tag to it. The “Player” tag should already exist in Unity

Attach Scripts

1. Find the folder “Museum Scripts” in the Project panel.

2.Drag the scripts “ArtifactInformation” and “ObjectRotater” to each object you wish the user to interact
with.

http://gmv.cast.uark.edu/wp-content/uploads/2012/06/sphere_collider.jpg
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3.The “ArtifactViewer” script has to go in a special place on the FPC. Expand the FPC in the Hierarchy panel
and locate the “Main Camera” inside of it.

4.Drag the ArtifactViewer on to the “Main Camera.”

Add info about the artifacts

Now if you select the artifact, you’ll find where you can enter information about the artifact. You can copy
and paste data from the Hampson site or come up with your own.

NB: Although the Artifact Description doesn’t show much of the text, it really does have a block of text in it.

Finished Museum Demo

Now if you click Play, you can click on the object and a GUI with information appears. Left clicking will also
allow you rotate the model. If the rotation seems off, the pivot point may not be in the center.

You should now have a simple walkthrough demo of a museum.

This project was designed as a launching platform for more ambitious projects.
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This series of posts will teach you how to navigate in Unity and to create a basic virtual
museum. 
Hint: You can click on any image to see a larger version.

Intro

This chapter will show you how to put together a walkable demo of a simple museum using several
models. The techniques in this tutorial can be applied in many ways. Although I use models from the Virtual
Hampson museum as examples, you are welcome to use your own.

You will need to download the following model, or use one of your own:
https://dl.dropbox.com/u/22781413/museumdemo/simpleMuseum.zip

You can take a look at the final product here.

Create a new project

Open Unity and go to File > New Project.

The New Project file dialog will come up.

Name the project “Museum Demo” and save it in a convenient location.

Below you will see the packages Unity comes with. A package is a set of scripts and assets that allow
certain functionalities. For this demo, we will choose:

- CharacterController
- Skybox

Unity will open with an empty scene.

Import the model

Now we’ll import the simpleMuseum model. Either we can copy and paste the file into the asset folder using
Explorer or we can drag and drop the file into the Project panel.

https://dl.dropbox.com/u/22781413/museumdemo/simpleMuseum.zip
https://dl.dropbox.com/u/22781413/museumdemo/simpleMuseumDemo/simpleMuseumDemo.html
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Click on the model in the Project panel, and its Import Settings will show up in the Inspector. You’ll want to
do two things here.

1.Check the Generate Colliders box.

2. Adjust the scale factor. Every modeling application processes units differently. (For the simpleMuseum
model, try a scale factor of .01 ).

Scene View

Now we’ll drag and drop the model from the Project panel to the Scene view.

The First Person Controller

It’s hard to see if the scale is off without another model for comparison so we’ll also drag and drop the First
Person Controller into the scene.

You can find the First Person Controller* (FPC) by locating the Standard Assets folder in the Project panel
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and looking in the Character Controllers folder. You will see the 3rd Person Controller and the FPC .

NB: If you do not find the FPC, go to Asset > Import Package > Character Controllers and Import All.

Drag the (FPC) into the scene inside the museum model.

FPC is raised off the floor. If the FPC is partially through floor, the camera will fall to infinity. If the FPC is
high above the green plane, it will fall until it collides with it.

FPC and model scale

The FPC is 2 units tall. Unity works best thinking the units in meters, but it mainly depends on the units
used in the modeling application. If the model is larger or smaller relative to the FPC, you can adjust the

Scale Factor accordingly. 
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Preview the Model

Press the Play button at the top. This will compile the scripts and show you a preview. You can walk around
using the arrow keys or WASD. You can look around using mouse movement. You can even jump with
space bar. We’ll adjust these controls later.

If the camera falls through the model, either the FPC wasn’t raised enough off the floor or “Generate
Colliders” wasn’t checked in the Import Settings.

Scene Lighting

Likely, the preview will be dark and difficult to see clearly. Let’s add a light to the scene.

Unity provides three types of lighting typical for 3D applications: Spot, Directional, Point.

Point light is an omnidirectional point of light. Directional light imitates sun light from an angle. Spot light is
a concentrated area light. To light an entire scene, we will add a directional light.

Click on GameObject > Create Other > Directional Light.

Edit Unity Lighting

Press E to go into rotate mode and rotate the light to obtain the desired lighting. The position of the light is
irrelevant. You can change the color and intensity in the inspector while you have the Directional Light
selected.

Invisible Colliders

Sometimes it’s convenient to be able to tightly control where users have access to. An easy solution for
blocking user access is to place invisible colliders around the prohibited space.

You’ll definitely want to block access anywhere the user may fall infinity and break the user experience as
in our current museum demo.
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Adding invisible collider is very simple. We’ll start by adding a cube to the scene.

1.Go to GameObject > Create Other > Cube
2. Press ‘F” to focus on the cube

A cube appears in the scene view.

Moving the Cube 1

We’ll move the cube to the edge of the green plane. We’ll use vertex snapping for moving objects next to
other objects.

1. With the cube still selected, holding down ‘V’, a square gizmo will appear over the nearest vertex.

2. With ‘V’ still held down over the desired vertex, click LMB and the cube will snap to the nearest vertex of
another object. Drag the cube so that it lines up next to the edge of the green plane.

Scaling the Cube

3. Now press ‘R’ to go into scale mode and scale the cube along the X axis(blue handle) along the full width
of the green plane. Then scale the cube of the Y axis (green handle) so that the cube is taller than the FPC.
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Hide the Cube

4. Finally, with the cube still selected, go to the Inspector and uncheck the box next to MeshRenderer.

This will render the cube invisible, but the collider will still be in effect.

Skybox Creation

Now we can duplicate the object (Ctrl D) and reposition the duplicates adjacent to the other edges of the
green plane.

Unity provides a number of skyboxes you can use. If you did not import the Skybox package when you
created the project, you can import to Assets > Import Packages > Skyboxes, then click the Import button
on the popup window.

Now go to Edit > Render Settings and in the inspector you’ll find Skybox Material.

Click on the little circle next to it and you’ll open the Material Browser. Unfortunately, it will show every
Material existing in the project and will not cull out those only suitable for Skyboxes. But since Skybox
materials usually have “sky” in the name, if you type “sky” in the search bar at the top, the browser will
only show those materials suitable for Skyboxes. Unity provides various day and night time skyboxes.
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Motion Adjustment

Most likely you will want to fine tune the motion controls and interactive experience of your walkthrough
model. We’ll take a look at adjusting the speed of your movement, sensitivity of the mouse and look brief at
how we can modify the scripts Unity comes with.

Character Controller Menu

Select the FPC and you will see in the inspector how the FPC is constructed from individual components.

The Character Controller allows you to adjust the width and height of the FPC among other things.

The Character Motor Component

The Character Motor component allows you to adjust movement speed.

-Expand the Movement hierarchy and you’ll find the Max Forward, Sideways and Backwards Speed, as well
as Gravity and Ground Acceleration.
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-The most effective strategy for fine tuning is to be in Play Mode and adjust the values. Anytime you adjust
a value it will be reflected in the Player. Once you have values that seem appropriate, either take a
snapshot of the values or write them down. When you quit Play Mode, the values will reset to their original,
and you must enter them in again.

You can also adjust the Jumping or disable it completely. It is unlikely you will need to worry about Moving
Platform and Sliding.

Mouse Sensitivity

Looking around with the mouse may seem jarring or disorienting, but you can tweak these values so you
can have a smooth experience. But we will have to look in two different locations. Unity handles X and Y
rotation differently for the FPC. To adjust the mouse sensitivity in the X axis, with the FPC selected, look at
the Inspector and find the Mouse Look component. MouseX should be selected in the Axes. Adjusting the
Sensitivity X will adjust the mouse sensitivity in the X axes. Adjusting the Y will have no effect.

To modify the Y Sensitivy, select the FPC in the Hierarchy and expand it. You will find Graphics and Main
Camera. Select main Camera and you the inspector will show another Mouse Look component. Adjusting
the Sensitivity Y will modify your mouse movements up and down.

You can also decide how far the user can look up and down by adjusting the Minimum Y and Maximum Y
values

http://gmv.cast.uark.edu/wp-content/uploads/2012/06/character_motor_menu_unity.jpg
http://gmv.cast.uark.edu/wp-content/uploads/2012/06/mouse_sensitivity_unity1.jpg
http://gmv.cast.uark.edu/wp-content/uploads/2012/06/mouse_sensitivity_unity2.jpg


Continue…

These are the basics for a walkable demo in Unity. We will next look at adding a mechanism for gathering
information in our walkable demo.

Extra:

A museum should have artifacts! Download several Hampson artifacts, import them and place them on the
pedestals inside the museum structure. You can use them in the next tutorial. Be sure to use a scale factor
of .005. Leave the Generate Colliders box unchecked.

Continue here…
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This series of posts will teach you how to navigate in Unity and to create a basic virtual
museum. 
Hint: You can click on any image to see a larger version.

Basic Importing

Unity3D reads these file formats natively:
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-FBX : an AutoDesk format designed for interoperability

-.dae : Collada format *

-. 3ds: 3D Studio Max

-.dxf : Drawing Interchange Format, a format used for interoperability between AutoCad and other
programs

-.obj : Wavefront Object, an open and fairly common 3D model format

If you are working in a 3D modelling application and are able to export in one of these formats, Unity will
be able to read it. Export the file into the Assets folder and the object will appear in your Project panel in
Unity. For best results, always import as .fbx or .obj files. Unity works best with these particularly when it
comes to scale.

FBX Converter
Autodesk supplies a free FBX converter on their website. You can find it here:
http://usa.autodesk.com/adsk/servlet/pc/item?id=10775855&siteID=123112.

Automatic Import

Unity is able to automatically import a number of 3D models from the following proprietary vendor format.
The links will take you to Unity’s reference manual where you can find a fuller discussion of the vendor
format.

● Maya
● Cinema 4D
● 3ds Max
● Cheetah3D
● Modo
● Lightwave
● Blender

If you save the scene from any of these modeling packages to the Asset folder you are working in, Unity
will automatically import them in the project. You can freely go to and fro Unity and the modeling package
and all edits will be reflected in Unity.

2D Assets

Similarly, Unity reads Photoshop files natively so you can save your .psd files straight into the Assets folder.
It’s a good idea to create a folder named Textures to keep your files organized. Using the Photoshop
documents natively allow you to make edits and see the results quickly in Unity. However, you may see a
lost in quality using Photoshop Documents. To avoid this, try using 24 bit PNG files. An advisable
organization strategy is to save your PSD files in a folder called PhotoshopOriginals and export the png files
into the Texture folder in your Asset folder.

Continue…

Continue to read about Unity here…
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This series of posts will teach you how to navigate in Unity and to create a basic virtual
museum. 
Hint: You can click on any image to see a larger version.

The interface

The Unity interface can be daunting on first glance. But, for getting started, we can break it down into four

sections.

Scene View

http://gmv.cast.uark.edu/wp-content/uploads/2012/06/hampson.jpg
http://gmv.cast.uark.edu/wp-content/uploads/2012/06/interface.jpg
http://gmv.cast.uark.edu/wp-content/uploads/2012/06/sceneview.jpg


This is your 3D view, though it differs from 3D views in Blender or Cinema4D. You don’t edit 3D geometry
directly in this view. Rather, you use it to place things precisely where you wish them to go. If you wish to
edit your geometry, you’ll either need to open it up in a 3D modelling application or install additional
components into Unity. You can also see the hierarchical structure of how your scene is composed in the
Hierarchy panel below.

Basic Movement in the Scene View

Unity uses key shortcuts similar to Autodesk Maya, but you can change them easily by going to Edit >
Preferences.

Look around in your scene
1. Hold Right Mouse Button (RMB) while dragging your mouse sideways will rotate the camera in place.

Rotate around in your scene
1. Holding ALT and press Left Mouse Button (LMB).

Zoom In and Out
1. Hold ALT and RMB, and then drag your mouse in or out or sideways.Alternatively, you can use the drag
wheel

Centering on an object.
1. Select an object either in the Scene view or the Hierarchy view.
2. Make sure your cursor is hovering over the Scene view.
3. Press ‘F’ to “focus” in on your object.

Basic Object Manipulation

You can use the controls in the top left corner to get into any mode.

The gizmos around the selected object in the Scene will change depending on which mode you are in.

‘W’ : Will put you into Move model

‘E’ : Rotate mode
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‘R’ : Scale mode

The Project Panel

The Project panel is your library of readily available assets you can use in your current scene. Any models
or artwork you wish to place into a scene can be dragged from this panel to either the Scene view or the
Hierarchy view. When you want to add assets into the Project panel, just save them to the Asset folder
inside the Project folder you created at the start. If you have trouble locating where you saved your Unity
project, right click on any asset in the Project panel and click on Show in Explorer.

Unity also provides a number of assets ready to go. These are located in the folder named Standard Assets.
If you do not find a particular asset here, you might not have imported them when you created the project.

You can easily reimport them by going to Edit -> Import Packages -> DesiredPackage. We will look at the
packages in more in depth in the next chapter.
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The Inspector

Finally at the far right is the Inspector. This shows attributes of what you have selected. If you just have an
empty game object selected, it will only show you the Transform attributes, which are its Position, Rotation
and Scale. This is the base component of all GameObjects. You can position, rotate, and scale objects
precisely using the coordinates in this field.

GameObjects are the heart and soul of Unity. Everything in Unity is a GameObject and you add functionality
by adding Components to GameObjects much like adding layers to a Photoshop document. Common
components are Character Controllers, Rigidbody, Particle Systems, and Audio Files. You can add custom
functionality by creating scripts and adding them as components to various GameObjects. You can create
subtle complex interaction by layering a few components to various gameobjects.

Continue…

Continue to learn about Modeling and Unity here
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Once it has been determined that a site is a good candidate for geophysical investigation, and appropriate
geophysical methods and instruments have been selected, the next step is to plan the survey. Project goals
and expectations based on previous investigations often help one develop a sampling strategy to guide the
geophysical work. Large continuous areas are almost always more informative than small, discrete patches.
Once it has been determined that the available instruments and selected survey strategy are detecting
anomalies that appear to be consistent with archaeological features, a ground-truthing strategy should be
considered to aid in directing the progress of geophysical survey. In general, it is best to begin geophysical
surveys in more promising and better understood areas as a baseline before moving toward the lesser
known. When a site is very large, and there are generally no clues as to where subsurface features are
most likely to be located, choose a readily accessible portion of the site that is not in need of much
preparation work (vegetation removal, etc). After collecting a day’s or half-day’s worth of data, hopefully
the results will help you decide which way to progress. At large sites it is often best to select a few discrete
locations for test surveys. If possible, keep them on the same grid system, so that they will eventually be
connected if the survey is expanded.

Survey location and size

Geophysical surveys can vary greatly in size.
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• Ideally, a survey should extend a little beyond the site limits
• ensure that the area surveyed is large enough that features can be recognized based on pattern
recognition
• Small features can be detected with small surveys, perhaps 15 x 15 meters or even smaller in special
cases. Such small area samples may, however, make it very difficult to interpret distributional patterns.
• Much larger surveys have the benefit of revealing not only individual features and feature clusters, but
entire settlements. At this “landscape” scale, the spatial layout of complete sites can be documented, and
entire settlements (or, in many cases, settlement palimpsests) can be investigated.

Setting up grid

The importance of accurately setting up a grid cannot be stressed enough. If the grid has internal error, or
if it cannot be accurately located on the ground in relation to a base map, then the value of the geophysical
survey is greatly diminished. Copious notes should also be taken so that the grid can be relocated in the
future. (The term “grid” can be confusing sometimes because it is used in many different ways. To avoid
confusion we use the word “grid” here in the traditional sense, and describe the individual geophysical
survey units in a grid as “tiles.”)
There are a variety of ways to set up a grid for geophysical survey. For small areas, tape measures can be
used without the help of a transit or similar device. Right-angles for tile corners can be closely

approximated using the Pythagorean Theorem.  This method works well for small
grids, but as the size of the grid increases, the error gets progressively worse. When relocating a point on
the ground to investigate an anomaly, one should tape distances from the corner of that particular tile
where survey began. In order to correct error later it is important to record the GPS locations of the tile
corners. A dumpy level or an optical square can be used to sight in straight lines and right angles, but
taped distances will still be erroneous the farther the grid is extended from the starting point. A much more
accurate and precise way to set up a grid is to use a total station or survey-grade GPS.
The orientation of a grid with respect to architectural or other linear features is extremely important.
Several problems can occur if data are collected along lines that are parallel to walls or other linear features
(e.g., ditches, fences, roads).
• a narrow linear feature could be entirely missed if it falls between collection traverses
• Lines can be easily mistaken for instrument malfunction or interference from outside sources
• anomalies that parallel collection lines will often be removed by a de-striping filter
It is therefore important to choose a grid orientation that is at least 20 degrees offset from the dominant
trend in architecture. Where possible it is beneficial to set up the grid close to 45 degrees offset from the
architecture (or linear features of interest).

Tile Size

Tile size is often a difficult decision to make, and there are many factors to consider. Using very small tiles
(e.g., 10 x 10 m) over a large area will result in a large number of data files. If tiles are too large (40 x 40
or larger), it will take too long to survey each one and the surveyor will probably need to take breaks
before a tile is complete. Large tiles have several problems
• most instruments drift over time, small tiles allow for re-calibration
• when survey is resumed after a break, the readings of the new line will not match well with the line of
data collected before the break, so an edge-discontinuity is created
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• Data collection has to stop at the end of the day or when batteries are drained, so it is best to use a tile
size that is both large enough to keep the number of data files manageable, while also small enough that a
tile can be finished in under an hour.
• Small tiles are better in oddly shaped or confined spaces
• Managing “walking ropes” or tape measures difficult over large distances
Small tiles are also easier when there are other things going on during the survey that need periodic
attention, such as talking to the public, helping with other parts of the field effort, or attending to a GPS
unit or battery charger.
Another factor to consider with tile size is uniformity. When using multiple methods at one site it is best to
pick one tile size for all instruments. This way, the grid can be set up with markers at every tile corner, and
a single set of pre-cut survey ropes can be used for all instruments. A common method in North America is
to lay out a grid with markers every 20 meters. The most commonly used software packages for
magnetometry and resistivity (Geoplot and ArchaeoSurveyor) also follow this convention and require that all
tiles be the same size in order to be displayed and processed together, which simplifies programming. Note
that Archaeomapper is designed to process edge discontinuities that occur between and within tile
boundaries with ease, and allows tiles of different sizes and data densities in the same survey. We suggest
that ropes be laid down along survey lines at all odd meters (1, 3, 5, and so on up to 19 m). Using this
technique, there are no locations in the tile that are more than 1 m away from a survey rope, so distances
along each transect can be easily estimated for rapid survey.

Ground penetrating radar survey is distinctly different from the other methods. We suggest that larger tiles
be used to minimize processing time using 40 x 40-m tiles.
• The edges line up with the typical 20 x 20 m tile boundaries of other surveys, but there are only one
quarter as many tiles to process.
• at half-meter line spacing it is likely that a tile can be surveyed in 3-4 hours.
• Two 50-meter measuring tapes are used for baselines and a third one as a “walking tape,” which is
moved along as lines are surveyed.
• Keep in mind, however, that this method requires at least two and preferably three people, and does not
leave much time for breaks during the long surveys.
With EMI, larger tiles are not recommended because, unlike GPR, EMI data (both conductivity and MS) are
prone to drift. With a sensor that drifts it is better to tune it frequently, such as before each 20 x 20 m tile.

Data Density

The ability to detect small or low contrast features depends heavily on the data (or sampling) density of the
geophysical survey. The limiting factor for feature detection and image resolution is therefore the distance
between lines. The traditional sampling density for most methods is reported to be 1-2 samples per m². We
suggest that the traverse interval should be geared to the nature of the site and expected features. Data
density should be high enough such that the smallest feature to be detected is recorded at least twice and
preferably more for reliable detection. This means that if the target feature is 1 m in diameter the data
density should be at least .5 x .5 m so that it is likely to be recorded more than once and thus
distinguishable from a data spike.
Unfortunately, the advantages of high data density surveys are accompanied by higher costs. A balance
between meeting the survey goals and costs should be found. This sometimes means surveying a smaller
area with higher data density rather than a large area at a lower density, or vice versa. Some software
packages (including ArchaeoMapper) allow one to remove every other line of data in order to assess the
impact on anomaly detection. Where this capability exists, it is wise to begin with a higher density survey,
and reduce this if anomalies consistent with features are detected using the lower density.

Data Density 2

The term data density can sometimes be confused with image resolution. Data density refers to the number
of data values per m² collected in the field. During processing, interpolation procedures are used to
cosmetically improve an image by reducing pixel size. Such interpolation is, however, no substitute for an



increase in true data density, and it will not aid in the detection of small or low contrast features.
Many instruments are designed to record measurements at regular intervals along each transect. Most
magnetometers and EMI instruments emit an audible beep at regular intervals, such as every second, in
order to guide the surveyor. The surveyor can then choose how many measurements will be taken between
each beep, or can alter the time interval between beeps. This requires that the surveyor is able to proceed
at a fairly constant pace. If there are many obstacles, readings can be taken manually by pushing a button,
although this is difficult in situations where 8 readings per meter must be recorded. Alternatively, some
instruments allow the surveyor to keep track of distance continuously by recording a fiducial-mark every
meter or so. The meter marks are then used to interpolate, or “rubbersheet”, between markers. This is
often done with GPR, but an easier way to record GPR data is to use a survey wheel. The wheel attaches
to the antenna and works as an odometer, taking an equal number of measurements per meter.

Ground Surface Preparation

While it is ideal for a site to be blanketed in short, smooth grass, most sites are covered in some
combination of tall grass, cacti, bushes, and trees. The ideal solution is to remove any vegetation that
impedes the movement of geophysical equipment. The method of vegetation removal should be carefully
considered. A lawn mower can be used to clear grass, but care should be taken not to do this on days
when the ground is soft because shallow tire tracks can be detected by most geophysical methods. If
bushes are removed, they should be chopped down to ground level but the root system left in place rather
than removed because this would create an anomaly on its own.
As discussed previously, metal debris on and near the surface creates a problem for magnetometry survey,
and to some extent conductivity. If metal debris is extensive, then magnetometry survey is not worthwhile
until the debris is removed. This adds considerable time and cost to the project, because removing metal
entails locating each piece with a metal detector and then usually digging for it with a trowel. This kind of
impact might not be acceptable at some (unplowed, cemetery, battlefield) sites. It is a worthwhile effort,
however, when magnetometry is the best method for meeting the survey goals.

Survey Supplies

A variety of field supplies are either required or very helpful for a geophysical survey, particularly for large
surveys using multiple instruments. Here we provide a list of basic supplies needed for a survey, but it is
not exhaustive.

Tile corner markers. Plastic sections of ½-inch diameter pvc pipe works well to mark tile corners. They can
usually be pounded in easily and are readily visible. They can be written on with permanent marker to show
the grid coordinates and tile number, or marked with flagging tape that bears this information.

Plastic or wooden stakes. These are best for pinning survey ropes across grid tiles, and can also be used as
tile corner markers. Compared to wooden stakes, plastic stakes or ten pegs are easier to work with, last
much longer, and are often cheaper.

Flagging tape. This is useful to mark stakes or other tile markers, and other locations.

Plastic Pin flags. Pin flags are useful for marking tile corners, tuning stations, and monitoring stations.
Plastic is much preferred over metal for the sake of magnetometry. We advocate that archaeologists never
use metal pin flags at sites that may someday be the subject of geophysical survey.

Rubber mallet. A mallet or hammer makes pounding in stakes easier, and one made of rubber is less likely
to damage them. Rubber mallets often include some metal, however, so they should be tested before being
left within range of a magnetometer.

Tape Measures. Tape measures are needed when laying out a grid unless a total station is available. They



can also be used to stretch out along baselines to set up tiles for survey. It is handy to have three tape
measures, 30-50 m long each. It is also nice to have one 100-m tape that you can stretch along a series of
tiles, or use to measure the hypotenuse when setting-in tiles. If large GPR tiles are being used, tape
measures are best for guiding the survey.

Chaining pins. These can be used to secure one end of a tape, allowing one individual to establish a series
of tiles. Make sure to remove them prior to magnetometry or EMI surveys!

Survey ropes. Survey ropes are precut sections of rope with meter markers that are highly visible. They are
used to lay out a tile for survey. If the typical 20 m tiles are used, then these ropes should be made long
enough to lay across the entire 20 m, with some slack at the ends so a loop can be tied. Meter marks can
be made visible with brightly colored spray paint, duct tape, or electrical tape. It is also helpful to use
different colors to mark increments, such as every five meters, so that distances along the rope can be
easily determined. Fiberglass survey tapes, which do not stretch, are available in large rolls from many
survey suppliers.

Notebook and pencils. Obviously there is much information to record in the field. Books with grid lines are
helpful for sketching the site grid.

Pre-made Forms. For large surveys especially, it is useful to develop a standard form that can be used to
record information about each tile. It saves time if the standard-sized tile is already drawn on the form that
can be used to sketch in anything on the surface that will affect the interpretation of the data, such as
vegetation patterns and the locations of obstacles. If doing resistivity, it is also useful to record the
measurements from each tile coner, so that when survey is continued the remote probes can be
repositioned to make adjacent tiles match.

Compass. This is especially important for magnetometry, because tuning and set up require that magnetic
north be located rather accurately.

Tunings Stands. Fluxgate magnetometers can be tuned standing on the ground as instruction manuals
advise, but it is much better to be elevated above the ground. A plastic or some other non-metal stool can
be used for this. It is particularly important for dual sensors, because if they are close to the ground they
could each find a different zero, resulting in a strong striping pattern in the data. EM instruments,
particularly the EM38, also should be elevated high above the ground for tuning. While the instrument can
be held this way while standing, it is very tiring and probably not as accurate because it is not held
perfectly steady and at the right angle. A collapsible platform can be made out of pvc pipe or some other
non-metal material. Use of a bubble level to ensure that the instrument is being held vertically can reduce
the time needed to properly tune a Geoscan gradiometer.

Total Station or some other mapping implement. A total station is best, but an optical transit, dumpy level
or optical square can be used for small grids.

GPS unit. The geophysical grid should be mapped into real world coordinates if possible, for record keeping
and integration with other data in GIS.

Portable Computer. This is necessary to download data, as most instruments do not hold more than a day’s
worth. It is also important to take a look at data each day to check for errors and see how the methods are
working.

Software. The download and processing software for each instrument should be loaded onto the portable
computer, but it is also a good idea to have a back-up copy on disk in case the computer fails.

Means to establish a permanent datum. The geophysical data are not worth very much if the grid cannot be
relocated on the ground surface in the future. Unless the real-world coordinates of the grid are known (and
can be precisely relocated with a GPS), the geophysical grid should be marked with a datum that will last at
least long enough to be more accurately documented. A post-hole digger or shovel should be used to dig a
hole and fill with cement, with rebar or pvc pipe embedded for visibility. Sometimes the datum should be



low to the ground so it will not be removed, damaged, or pose a danger to passing vehicles. Use of rebar is
debatable. It is more durable than PVC, and can be relocated with a metal detector, but will cause a large
anomaly in future magnetometer surveys. If using rebar, consider temporarily removing it prior to any
future magnetometry surveys.
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