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This workflow will show you how to use Leica’s COE plug-in to import and export objects and points in Cyclone.
Hint: You can click on any image to see a larger version.

IMPORTING & EXPORTING

Importing & Exporting Objects and Points in Cyclone with COE Files

I. Importing files into Cyclone is done through the Navigator window, where a new MS is created with the imported file -> Open Cyclone Navigator -> Select
Database/ModelSpaces Folder -> RC -> Import -> browse to COE file -> Open -> MS View appears named by default with the COE file location

NOTE: You cannot import a COE into a MS view, rather it must be imported into the overall “ModelSpaces” project folder at which time a new MS view is created
for editing.Â  While most objects can be imported into Cyclone, complex objects (ie: beveled edges, rounded corners, notches) may be translated into a collection of
lines and arcs versus objects when imported

MANAGING THE COE-MS

II. Managing the COE-MS -> Open the COE ModelSpace that has automatically been created -> It is recommended that you group objects and place them on individual
layers as needed in this original COE MS (to group -> Select Objects -> Edit -> Group -> Group -> Objects can be ungrouped at any time with this command as well) ->
Copy all objects -> Close COE MS

PASTING COE OBJECTS INTO ORIGINAL MS

III. Pasting COE objects into Original MS -> Its highly recommended to copy and paste the original MS as a copied/working MS in Cyclone Navigator; use this copied
MS to insert objects, updating the original MS only as a final step -> Open copied MS -> Paste objects that were copied from COE file in Step II -> NOTE: if coordinates
were maintained and referenced throughout the modeling and export process, the object should automatically paste into the correct position. If references/links have been
lost, the imported objects may need to be moved/rotated (select objects -> RC -> move/rotate)

NOTE: When moving grouped or multiple objects, faces and lines may appear to remain in their original position or become displaced during manipulation; as long
as all objects are selected or grouped/selected, this is only a refreshing issue -> View Properties (Shift + L) -> Selectable/Visible Tab -> toggle the visibility of the
object type off (ie: mesh or patch, etc) and when toggled back on, the view of all objects should be refreshed.

COMPARING MODELED OBJECTS WITH ORIGINAL POINTS

Comparing Modeled Objects with Original Points in Cyclone

I. Import the COE file into Cyclone Navigator

II. Upon importing, the COE creates its own MS that loses many of the editing/manipulation options -> Open the COE MS -> Select All -> Copy -> Open Working
MS (containing points to compare/analyze) -> Paste COE object(s) into Working MS; NOTE: Pay attention to the layers in Cyclone: all ACAD layers accompany the
object when imported however when copied/pasted objects are placed on a layer named ‘default~’; Manually assign the correct layer to the object in the Working MS and
delete unnecessary layers.

CALCULATE MESH TO POINT CLOUD DEVIATION

III. Calculate Mesh to Point Cloud Deviation -> Multi-select the object mesh and the point cloud (Its recommended to view the mesh in “per-face normals” setting >
Shift + L for Layers > View As tab) -> Tools -> Measure -> Mesh to Points Deviation -> Dialogue Box Options:

Slider bar allows user to adjust and preview deviations on the mesh faces above a user-set limit; minimum and maximum boxes are read-only
Distance computation – user decides whether those faces that are highlighted are based on maximum or average deviation and Absolute (no positive/negative
distances) or Signed Distance
Details – displays total mesh faces, # of faces deviating, what percentage of the whole that represents, and total # of points

CALCULATING DEVIATION – CONT.

IV. Calculate Object to Point Cloud Deviation when Object is created in Cyclone > Object (ie: cylinder, primitives) -> after creation, select object and RC -> Info
dialogue tells Fit Quality including Error Mean, Error Std. Deviation, and Absolute Errors; Interfering Points may also be calculated

V. Calculate Object to Point Cloud Deviation when Object is created outside of Cyclone -> Interfering Points -> Multi-select object and point cloud -> Tools ->
Measure -> Interfering Points -> Dialogue box appears in which user can adjust the tolerance to calculate -> all cloud points that are within the user-specified distance of
the selected object are highlighted and can be segmented from the rest of the cloud (See Cyclone help ‘How to Segment interfering points’ for more details) and dialogue
box displays the percentage of points interfering and the percentage of points inside the object (useful in volumes); this analysis is limited in many modeling applications
as accurately modeled objects rarely lie completely on one side of the points referenced
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In this series, columns in a deteriorating colonnade will be modeled by several methods.
Hint: You can click on any image to see a larger version.

 

CLOUDWORX

Comparing Modeled Objects to Original Points in this example

(analyzed at .005 m (.5 cm) / average distance of deviation/ absolute value)

I. CloudWorx – three section cuts in the x or y direction – lofted in the z (up) direction to create 3D solid column:

Â· 7% of the mesh faces (ie: 484 of 6,914) were above .5 cm deviation from point cloud

CLOUDWORX 2

II. Cloudworx – 1 section cut in the z direction (representing 1/2 the column from outside edge to center) – revolved around center axis
to create 3D solid column

Â· 43% of the mesh faces (ie: 6,055 of 14,160) were above the .5 cm deviation from point cloud

http://gmv.cast.uark.edu/wp-content/uploads/2011/05/clip_image0501.jpg


CYCLONE

III. Cyclone – Mesh created in Cyclone from point cloud

Â· < 1% of the mesh faces (ie: 977 of 334,133) were above the .5 cm deviation from point cloud
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In this series, columns in a deteriorating colonnade will be modeled by several methods.
Hint: You can click on any image to see a larger version.

USE THE CLOUDWORX SLICE TOOLBAR

Method 2: Slicing Single Cross Section and Revolving the Profile Around Center – Similar to the first method, the column will be sliced and traced; however here, a
single profile will be traced and revolved around the center, creating a solid or surface object.Â  Follow steps in Method 1, Section I for setting up the ACAD model space
and isolating the colonnade.

I. Use the CloudWorx Slice Toolbar to slice the point cloud from the top view (or whichever view allows you to see the entire diameter of the column/feature); this
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will be the only section profile that will be traced and we will only be tracing half of it; choosing the most complete/intact slice possible is recommended. See
Method 1 for details on slicing

Figure 7 (Left) Top view of the column; magenta lines highlight the slicing boundaries – (Center) Top view of the column profile slice – (Right) Front view of the column
profile slice

TRACE THE PROFILE AND SNAP TO POINT CLOUD

II. Trace the profile of the section cut, snapping directly to point cloud > Front or Side View > Make correct layer current > Zoom in to view points comfortably

and refresh point cloud to confirm all points visible  (do this periodically, especially when zooming in/out) > Command Line: PL or POLYLINE and begin to
trace the profile/outline the profile of the section cut

REMEMBER: (1) Enable OSNAP “NODE” to snap to points (2) At command line: type “U” during active polyline command to undo vertices/go back without
ending the command (3) At command line: PEDIT allows polyline(s) to be edited, joined, etc. (4) See ACAD Help: Drawing and Editing Polylines for more
information

DETERMINE CENTER AROUND WHICH TO ROTATE

III. Determine the center around which to rotate > NOTE: there are a variety of ways to determine the center of a feature; one is outlined here. Also see the “fit pipe to
cloud” method (following section), which determines the center directly from the point cloud and places a polyline along the centerline >

A. After half of the profile has been traced turn on ORTHO mode, which restricts drawing to a 90-degree vertical and horizontal direction to ensure

clean angles for the rotation later 

B. OSNAPS – enable ENDPOINT and MIDPOINT -> Use ONSNAPS to draw a line that is perpendicular to the column’s profile polyline: the start
point snaps to the endpoint of the top of the column and the end point snaps to the point cloud on the opposite edge of the section cut – this line
represents the full diameter of the column. Draw another line in the same way at the bottom of the column (See Figures 12 & 13)

Figure 8 (Left) Front view of point cloud and polyline representing left profile of the column – (Center) Front view with the point cloud hidden – (Right) Original polyline
with perpendicular lines drawn at the top and bottom representing the diameter of the column

EXAMPLES
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Figure 9 -Â  Front view, close-up of the top of the column; on the left of the image, the yellow polyline is the original line tracing the point cloud profile (dense green
points). With osnaps, draw a line snapping to the end point of the original polyline. Ortho Mode ensures a perpendicular line to the opposite edge of the point

cloud/column (less dense green dots on the right side of the image). Repeat this process at the bottom to achieve the 3 lines shown in Figure 8.

USING OSNAPS

C. Use OSNAPS to snap to the midpoint of the line at the top of the column to the midpoint of the line at the bottom of the column – this line
represents the center of the column (TIP: When snapping to midpoint, a triangle and the word “midpoint” appears near the cursor) -> Use grips or
the TRIM command to trim the ends of the lines that protrude past the center line

NOTE: This method finds the center based on the diameter of the column at the top and bottom at the point of the slice, accounting for any
leaning/tilting along the z-direction; For generally upright features, drawing a line in the center and restricting it to the z-axis will result in more
regularized features with identical “up directions”

IV. Command line: PEDIT to edit the polylines and join them into a single closed polyline > PEDIT > Select original polyline > JOIN > Select centerline, top line,
and bottom line > ENTER 2X > Clicking on the polyline should confirm that it is now a single object (if it does not join, check to confirm no endpoints are snapped
to one another but they are NOT overlapping).

Figure 10 (Left) Draw a polyline from the midpoint of the top line to the midpoint of the bottom line – note the yellow triangle and ‘midpoint’ showing the OSNAP
constraint is active (Right) Polylines have been drawn, trimmed, and joined to form a single polyline representing the profile of the column from the center to the edge

ROTATE PROFILE TO FORM 3D OBJECT

V. Rotate profile to form 3D object > Create and make a separate layer for the 3D object and make it active > 3D Modeling main toolbar > EXTRUDE tab pulls down
to REVOLVE (see figure 4) or at command line: REVOLVE > select profile polyline > ENTER > “Specify Start point or define axis” > Select endpoint at the bottom of
the centerline > “Specify axis endpoint” > Select endpoint at the top of the centerline > “Specify angle of revolution” > ENTER to accept default of 360-degrees
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Figure 11 (Left) The centerline of the column is drawn by snapping from the midpoint of the bottom polyline to the midpoint of the top polyline (Right) 2D tracing of the
point cloud section cut is revolved around the centerline creating 3D object

6. Modeled object can now be edited or exported as desired.
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This workflow will show you how to use Leica’s COE plug-in to import and export objects and points in AutoCAD.
Hint: You can click on any image to see a larger version.

INTRODUCTION

Using COE Plug-In to Import & Export Objects and Points in AutoCAD

Leicaâ€™s CloudWorx and COE (Cyclone Object Exchange) applications allow the user to view, import, and export files between Cyclone and CAD software while
maintaining links and information. This relationship allows the user to take advantage of the accuracy of the point cloud data and the advanced modeling functions in
AutoCAD; it also makes comparisons, analysis, and visualizations possible.

The COE import/export tool allows points and modeled objects to be imported/ exported/edited between Cyclone and ACAD (objects can be imported/exported with or
without the point cloud data) and must be installed separately. Objects and points can be directly edited in the CAD environment. Importing/exporting points with the
COE tool is only recommended for small point sets (less than 1,000,000 points).Â  See the GMV guide ‘Leica CloudWorx 4.2 and AutoCAD 2012' for more information
about the CloudWorx application.

 

 

CONFIRM INSTALLATION AND SET UNITS

I. In ACAD, confirm that the COE tool has been installed (enter COEIN in the command line in ACAD; an import options dialogue box should appear).Â  If it is not
installed, download the installation file from the Leica downloads page â€“ check for updates as the plug-in changes as versions update). During installation, the .exe will
open AutoCAD, command line (F2) will note the installation and the availability of new commands such as COEIN & COEOUT.

II. UNITS -> To avoid complications, it is highly recommended to work in the same units as the Cyclone Files > CHECK UNITS IN ALL NEW DRAWINGS BEFORE
DRAWING, MODELING, OR IMPORTING > In new ACAD drawing -> Command Line: UNITS > Adjust options to match Cyclone > Generally, Type: Decimal,
Insertion Scale Units: Meters > OK

 

 

COE COMMANDS

III. The following COE commands may be accessed through these entries or through the toolbar
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COEIN :Import COE files into ACAD
COEOUT: Export contents of drawing to COE file
COEXPLODE: explodes blocks into individual objects
COEANN: toggles annotations from cyclone on/off

 

 

IMPORT OBJECTS INTO ACAD

IV. To import objects into ACAD -> command line: COEIN -> dialogue box appears -> Under ‘Import File Name’ browse for file -> Import Options:

Import objects as ACIS Solids -> imports objects as 3D ACIS solids
Import Objects as Blocks -> Blocks are made up of one or more objects that are combined to create a single object; using blocks results in the best compression
rate when objects are brought to ACAD (per Cyclone 7.0 Help) and are useful when repeating objects. When editing a block, all similar blocks are simultaneously
edited. A block must be exploded or “re-written” to remove or adjust this link between identical blocks. Dynamic blocks are more easily editable and are only
available in newer versions of ACAD. See ACAD help -> “Work with blocks” for more information
Import Point Sets -> In general, CloudWorx is recommended for large point clouds (1,000,000+ points), while the COE tool is recommended for objects and
smaller point clouds (less than 1,000,000 points) -> If Import Point Sets is selected and you experience problems/crashing, it is recommended that you either
decrease the size of the point cloud for import or that you use CloudWorx to view the point cloud versus import it
Log files -> log files are automatically created, adjust path as desired
Units Preference -> UNITS MUST MATCH (see Step II) -> In most cases, scan data is acquired in meters; if imported in a different unit, ACAD should
automatically apply a scale factor but using the same units avoids problems (If acquired and imported in the same unit, this scale factor will be 1)

EXPORT OBJECTS FROM AUTOCAD

 

V. To export objects from AutoCAD -> Toolbar or command line: COEOUT -> Dialogue box appears -> Browse to project folder and name file -> Select Objects to
Export -> OK -> Export Options:

Export objects USING ORIGINAL COE file as reference: When selected, the COE file that is created/exported from ACAD references the original Cyclone data
set enabling as much original object information/data as possible to be maintained when the object is brought back into Cyclone; select when integrating ACAD
data with the original COE file from Cyclone.Export objects WITHOUT original COE reference file: When selected, the COE file is new and maintains no
connection or reference to Cyclone data set or original COE file.
Export Objects: choose option All, Visible, or Selected objects
Units: as in importing in Step VI, UNITS MUST MATCH -> In most cases, scan data is acquired in meters; if exported in a different unit, a scale factor should
automatically apply but using the same units avoids problems (If acquired and imported in the same unit, this scale factor will be 1)

 

CONTINUE TO…

Continue to Using Leica’s COE Plug-In in Cyclone.
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This workflow will show you how to install and use Leica’s Cloudworx plug-in for AutoCAD. 
Hint: You can click on any image to see a larger version.

WHY USE BOTH PLATFORMS

Why use both platforms? : Leica’s CloudWorx plug-in allows the user to view, measure, and draft in an AutoCAD environment, referencing the point cloud. AutoCAD
does not load millions of points but treats the point cloud as a â€œread-only external reference fileâ€.Â  This relationship allows the user to take advantage of the
accuracy of the point cloud data and the advanced modeling functions in AutoCAD; it also makes comparisons, analysis, and visualizations possible.Â  You do not need to
have Cyclone installed on a computer to use CloudWorx as it is a standalone plug-in.

The CloudWorx Plug-in installs the menu and toolbars into CAD, allowing CAD applications to utilize/view point cloud data in a read-only format. The point cloud can
be viewed and referenced but it cannot be modified or deleted through CAD, thus the original point cloud data is preserved. CloudWorx is recommended for large data
sets (1,000,000 or more points).

NOTE: There is also a COE import/export tool available.Â  This allows points and modeled objects to be imported/ exported/edited between Cyclone and ACAD (objects
can be imported/exported with or without the point cloud data) and must be installed separately. Objects and points can be directly edited in the CAD environment.
Importing/exporting points with the COE tool is only recommended for small point sets (less than 1,000,000 points)

INSTALLING THE CLOUDWORX PLUG-IN

http://gmv.cast.uark.edu/6164/using-leicas-coe-plug-in-in-cyclone/


To Install the CloudWorx Plug-In:
I. Run executable file:CloudWorxForAutoCAD422.exe (this filemay be downloaded from the Leica downloads page – check for updates as the plug-in changes as
versions update). CloudWorx toolbars appear in AutoCAD workspace upon installation (see Figure 1).

NOTE: Changing/updating Cyclone software licenses (such as switching from a floating license to a node-locked license or vice versa) may affect the installation of
CloudWorx plug-ins. If licensing has recently changed and you experience problems installing or accessing plug-ins confirm that the Cyclone installation has been
updated -> Run original installation file > In dialogue box choose the “Update/Reinstall” option -> re-install the plug-ins. If this does not work, Cyclone may need to be
completed un-installed and re-installed.

Figure 1 CloudWorx Toolbar appears at
top of AutoCAD screen upon installation

II. Allow the installer to open AutoCAD to configure the plug-in.Â  AutoCAD should close automatically after this configuration.Â  If it does not close automatically,
close it.

INSTALLING CLOUDWORX CONT.

III.Â  After you have completed the Cloudworx installation, open AutoCAD > If the CloudWorx toolbar (in Figure 1) does not appear, type CWMENU into the
command line in AutoCAD.Â  Read the command line.Â  It should read “Customization file loaded successfully”.Â  If it was already configured, the command line states
“Customization file unloaded successfully” > If unsuccessful, type CWMENU again to load CloudWorx.

IV. If the toolbar does not appear although it shows as loaded, re-start AutoCAD.

V. In addition to the toolbars, you must also load the menu options > type MENULOAD in the command line in AutoCAD > type CloudWorx in the â€˜load custom
file fieldâ€ and close > A CloudWorx menu tab will appear at the top of the screen (see Figure 2)

Â Figure 2 CloudWorx Menu Tab appears once loaded

SETTING UP YOUR MODEL SPACE IN CYCLONE

Setting Up your ModelSpace in Cyclone :
Cyclone databases, with names ending in the .imp extension, are contained within the server on Cyclone; these files may be stored on a network; it is recommended to
copy the files locally while modeling; copy all files including the Database folder (containing the .impfile, pcesets, eventlog folder, and recovery folder) and the Scan
Folder (containing the Stations/scans, the ControlPoints.ini, and the project.ini).

I. Cyclone ModelSpace: Copy out feature or area to be modeled into a working MS -> Clean/delete un-needed data (be sure to view the data in all directions x, y, z)

II. Unify clouds to be modeled if they are not unified already (Select All -> Tools -> Unify Clouds)

III. Set Default Cloud > Select All -> Tools -> Scanner -> Set ScanWorld Default Scans â€“> Close (Dialogue box appears prompting for you to merge, remove, or
delete the MS.Â  DO NOT any of these, Select Close)

NOTE: It is recommended to create a unique, copied MS that is only used with CloudWorx; actively editing the Cyclone MS that is being modeled in ACAD can cause
visibility/access issues in the CloudWorx application

Â IV. Cyclone Navigator: Rename the MS and the MS view to identify the feature and to include the tag â€˜CloudWorxâ€™ to avoid future confusion > RC and
rename the MS and the MS View

V. Cyclone Navigator: Remove the database from the server > Configure > Databases > Select database > Remove > DO NOT DESTROY > Close Cyclone
Navigator

SETTING UP MODEL SPACE IN AutoCAD

Â Setting Up a Model Space in AutoCAD :
I. Create a New 3D Drawing > In ACAD -> Start Menu > New > Drawing > Choose 3D.dwt file in template library > Set Units (Generally, Type: Decimal and Insert
Scale Units: Meters) > The new drawing MUST be 3D; if you are not sure, create a new drawing and confirm this template.Â  See ACAD help if needed

II. Set ACAD Object Snaps (OSNAP) – Confirm that OSNAP’S are turned on and the node-snap is active -> Command line: OSNAP -> at dialogue box clear all and
check ‘Node’ -> OK -> Or use the OSNAP icon at bottom of the ACAD screen -> LC toggles osnap on/off and RC gives options/settings
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III. Default Coordinate System – By default, ACAD opens a World Coordinate System (WCS) which is coincidental with the scan world’s coordinate system. All
views, grids and many operations are based on the active coordinate system. If the desired feature to be modeled is aligned with a standardized axis within this system, no
adjustments are needed and modeling should take place in the WCS. If the section/slice is not aligned with a standard axis, ACAD’s coordinates can be temporarily
aligned to the User’s Coordinate System (UCS) to accommodate the slicing and modeling processes (see Aligning ACAD View below).

VIEWING A POINT CLOUD IN AutoCAD WITH CLOUDWORX

Â Viewing a Point Cloud in AutoCAD with CloudWorx :

I. ACAD: Configure Database to establish a connection with Cyclone’s database and point cloud engine > CloudWorx Main toolbar > Configure Database Icon >
Expand Servers folder > Highlight existing server (by default this is your computer) > Click Databases > Add > Browse for local .imp file > Open > OK

NOTE: Once a connection to the database is configured, you do not need to repeat this step, you can start with Step II: Importing a MS View

II. Select CloudWorx Icon to Import ModelSpace ViewÂ  > Dialogue box appears > LC the browse button > It may take several seconds to populate, be patient! >
Drill down to locate the MS View created in Cyclone (when you have drilled down to the correct MS view level, the ‘Open’ button will become active) > Select Open

III.Â  Confirm ACAD units (generally meters) & coordinate systems (by default, the coordinate system coincides with the system in Cyclone) > OK (this may take
several minutes when ACAD appears frozen, again be patient!)

IV. CloudWorx Visibility: > on main CloudWorx toolbar, select visibility icon > Confirm that point clouds are visible and can be snapped to

V. The MS will appear in the ACAD window.Â  Depending on the size of the MS you are viewing, this may take several seconds to several minutes.Â  If it does not
appear, zoom extents and you should see the extents of the entire MS represented with a point at each corner and the area you isolated in Cyclone as a denser area within
this boundary.

If the point cloud appears very sparse, click the Regenerate Point Clouds Icon .

If the point cloud still appears sparse, try adjusting the Point Density

Also note the point cloud viewing options: View Intensity Â and View Colors (RGB) from Scanner

ALIGNING ACAD VIEW

VI. Aligning ACAD View for Digitizing a top/plan view > > In a side or front view, zoom to the first object you are drawing (if zooming is hard to control when the
point clouds are referenced, use the zoom window for better control) > If the pre-set front/side view is not aligned to your object(s), use the orbit command to align your
view as much as possible

VII. Slice the cloud to represent your section cut >

LC on the CloudWorx Slice IconÂ  Â  to expand the options > Move down to the appropriate slice option and LC > Select the first/lower clipping plane by clicking
the endpoint of your lower reference line > Select the second/upper clipping plane by clicking the endpoint of your lower reference line > The point cloud is now clipped
to show the plan cross section cut.Â  To restore the entire cloud and remove the effects of the slice, select the ‘Reset all clipping’ icon .Â  Once you are satisfied, turn
off the ‘Slicing Reference’ layer.
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BEGIN DIGITIZING THE POINT CLOUD

X. Begin Digitizing the Point Cloud > If you are digitizing in three dimensions, use the snaps to snap to the cloud directly.Â  If you are digitizing in two dimensions,
disable the snap to cloud option Â and your drawing will be on a projection plane that is aligned to the coordinate system that is active while drawing.

NOTE: If you want to utilize the ability to snap to points, it is recommended that you snap to the points and then adjust the properties of the line work so that the elevation
and start/end z position are zero.

HIDING REGIONS

VII. Hiding Regions is useful to isolate a specific area or feature and to ease/speed up modeling and navigation in large data sets -> CloudWorx Tab -> Hide/Restore
Point Cloud (or icon on toolbar) -> Inside Fence -> draw polygon around area to model -> area is isolated as other points are hidden -> To Restore points ->
Hide/Restore Point Cloud -> Hide Regions Manager -> Uncheck the State check box -> OK. BEWARE: If a Cyclone MS has been previously configured in an ACAD
drawing, when opened in a new DWG the point cloud may appear with regions hidden from the previous configuration; if all points do not appear always check the Hide
Regions Manager and clear if needed.

TIPS

TIPS: If point cloud is not visible or only a few points are visible (especially upon re-opening a drawing) confirm:

1. Data is stored locally on computer
2. Cyclone MS: ScanWorld has been unified and ‘Set ScanWorld Default Scans’ has been set
3. Cyclone MS: Points are visible and selectable
4. Licenses are available and plug-ins have been installed
5. ACAD: Points have been regenerated -> command line: CWREGEN
6. ACAD: Confirm data cloud is present -> command line: LIST -> All -> Enter (twice) -> F2 expands history, which should show several objects listed as

CYPOINTBLOCKENT on CloudWorx layer
7. ACAD: clear all hidden regions and sections/slices that may be hiding cloud 8
8. ACAD: Adjusting visibility from intensity mapping to scanner color and regenerating also may help appearance
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This workflow is intended for users with minimal AutoCAD experience who want to learn the basic navigation and file logic.Â  As with any modeling program, there are
many ways to perform each function and every user has different methods/shortcuts to reach the same goals.Â  If you understand the concept and the priorities of the step,
use the tools to your best advantage and find your own methods for completing tasks.

See AutoCAD’s help menu and the many free tutorials on-line to help with questions and steps. ACADâ€™s user interface is fairly friendly. Often just typing the
command, all as one word without spaces, will either bring up the command or the appropriate help topic. Each new version of ACAD has changes in the interface but you
can always access primary commands in this command line.Â  Those new to the 2009 version of CAD may find the New Features Tutorial helpful.

Creating/Opening Files

To Open an Existing File -> In ACAD -> Start Menu -> Open (see figure 1)

When opening files from different versions of ACAD or containing different elements (such as an user-specific fonts or styles) a warning will appear when you
open the file.Â  If dialogue box asks for shape file (.shp) or states it cannot locate the shape file, close the box by clicking ‘X’ and the file will open, replacing the
unknown file with a default replacement file.
If a message appears regarding updating AEC elements, be aware that older versions of AutoCAD cannot read files saved in newer versions; in order to
open/manipulate a new file in an old version of CAD –> Open the file in the NEW version of ACAD –> File –> Save As –> File Type –> pull down to select the
appropriate version of CAD.Â  See the information on file types .dwg versus .dxf in the overview ‘File Formats’.

To Create a New .DWG (ACAD drawing) -> Start Menu -> New -> Drawing -> Template Library opens -> to work with point clouds and other 3D work spaces
choose “acad3D.dwt” -> template opens a 3D model space as a .DWG with a default file name -> adjust preferences as needed (see below) -> save file NOTE: The .dwt
name varies w/ version of ACAD – the goal is choosing the 3D template)
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Figure 1 ACAD’s start menu provides access to basic commands and types of modeling workspaces – user can move between Classic, 3D, and 2D work spaces or
customize a new one

File Formats

DWG – this is ACAD’s standard file format.Â  The type of .DWG format varies with each different release/version of ACAD in which the file was saved (by year).

DXF – or “Drawing eXchange Format” is a format that is standardized in different CAD and graphics programs. Â  This allows users to exchange drawings even if they
don’t have the same program. When you use the DXF format, some objects may change their appearance when re-opened.Â  See DXFOUT and DXFIN commands for
exporting and importing DXF files, respectively.

NOTE: 2004.dxf is a highly supported/interchangeable format and will often allow exchange with other software which may not successfully allow the .DWG.Â 
To save an ACAD file as a .DXF -> file -> save as -> pull-down file type to .dxf

BAK – this is ACAD’s backup file format; ACAD automatically creates a duplicate backup file.Â  If you original file becomes corrupt or un-usable, rename the BAK file
to a DWG file and open as usual.

SV$ -Â  This is AutoCAD’s format it uses whenever it performs an automatic save. AutoCAD will save the file automatically within a pre-determined time frame. Set the
time frame and the location of automatic saves in Options > Files dialog box.

Navigation

There are several methods to navigate in ACAD

Command Line - simple commands such as PAN, ORBIT, ZOOM can be entered in the command line.

ZOOM – Use the zoom icon or the middle roller on your mouse to zoom in/out; also type ‘ZOOM’ in command line for zooming options. Type shortcut ‘ZE’ to zoom to
the extents of all visible objects/points

Toolbars – Right click on the area where any visible toolbar is docked; this brings up your toolbar options.Â  ACAD contains the most basic toolbars. Activating the
toolbars for ‘Orbit’,Â  ’3D Navigation’, and ‘Views’ is recommended.

NOTE: When orbiting, a sphere is displayed with nodes shown on the top, bottom, left, and right – the cursor must be within this sphere (even if the
objects/points are outside of it) in order to rotate/orbit; placing your cursor over the nodes helps control orbit; the objects and points are not visible during orbit
but re-appear when the command ends

Mouse – by default the mouse is set to zoom in/out; RC also displays navigation options

Preferences/ Setup

UNITS - one of the most important preference to consider is units -> Command line -> UNITS -> Insertion Scale -> Set unit (maintaining the same unit as the scan data,
which is usually meters, is recommended)

NOTE: If point cloud data and CAD need to be in different units or coordinate systems, use ACAD’s point cloud dialogue box to define units and coordinates as
they will be used in ACAD -> Command Line -> POINTCLOUD -> Locate data -> Define units/coordinates -> data is converted to the scale/coordinates of the
ACAD drawing

Other Preferences -> Command line –> ‘PREFERENCES’

Files –> displays and allows you to edit paths for file saves (including auto saves), backups, etc

Display –> Screen & element colors, crosshair size, & display performance

Open & Save –> Automatic Save setting options (set to 10 minutes between automatic backup/autosave by default; this can be an invaluable backup or it can be a
frustrating time consumer – adjust this setting as needed based on file size and backup issues)

Explore other preferences and file options

Command Lines & Help Menu – Tips

Entering basic commands in their entirety or abbreviated into the command line is often successful and quick — ZOOM (Z), PAN (P), ORBIT, LINE (L), UNDO (U),
SAVEAS; You can scroll through the command history with the up arrow in the command line or by entering ‘F2'

Snap Icons – Directly below the command line, Snap icons allow quick toggling of drawing constraints used during modeling
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Figure 2 Active command line is highlighted in yellow; the user can scroll through the command history located directly above the active line; Snap icons are located
directly below the command prompt; Also note that the Model and Layout tabs at the top allow user to move between model space and paper space

 

Help – ACAD has strong help/search capabilities so when in question, a good place to start is the help menu accessed through -> command prompt –> HELP or File –>
Help or F1 Key or Typing keyword or phrase in search box located in upper right hand side of screen

Model Space, Paper Space, & Viewports

These are the names for the virtual spaces within ACAD.Â  They are controlled through the layout tabs

Figure 3 Layers Toolbar – LC on icon to open layer manager

 

Model Space = infinite 3D modeling space at 1:1 scale

**It is extremely important that from the very first step, you utilize the coordinate system in CAD. CAD is made up of infinite space and in order to keep your
project organized, understanding this infinite space is essential. By default, every ModelSpace has the same origin point located at 0,0,0 (meaning the x, y, z coordinates
are all at 0 – enter this value into the command line with no spaces). Recognizing and using the origin maintains a point of reference among various drawings. See the
‘Copying & Pasting Objects’ section below.

Layout/Paper Space = Virtual sheet of paper containing windows (or “viewports”) into model space.Â  Layout/Paper space can be scaled, labeled, and manipulated
without affecting the objects in model space.Â  Layout is the preferred space from which to print/plot.

Each layout is an individual “sheet of paper” containing an infinite number of viewports, labels, and text
elements & layers can be viewed independently between model & paper space by adjusting their visibility in the Layers Manager

Viewports = a 2d view used to project the 3d model space into the layout view.Â  It is similar to a ‘window’ that you place in paper space to look into Model Space.

Osnaps / Constraints

Osnaps and constraints are essential to utilizing the full accuracy and proficiency of ACAD.Â  Icons to toggle them on/off are located along the bottom of the screen,
below the command line (see figure 2)

Osnaps – when ON, they allow the user to “snap” drawing, modeling, and measurement tools to specific points on objects and point clouds (these points such as midpoint
or end point appear when the cursor hovers above the location on the object).Â  When OFF, these grips are not highlighted while drawing.

Infer Constraints – infers where objects, lines, or references would continue into space, allowing the user to snap to intersections/points that might not literally exist

Ortho Mode – restricts the user to orthogonal modeling/drawing

Polar Tracking – User can set a degree as a guide for modeling/drawing

Layers

Layers are the primary means of controlling objects in ACAD; organized, clearly-named layers are essential to managing the drawing.

Note if importing data from Leica Cyclone: When a point cloud is loaded into CloudWorx, Cyclone’s layers are transferred into ACAD layers (Cyclone names transfer
preceded by “~”).Â  Unless you have changed layer names in Cyclone, the point cloud is on “~Default” upon import.

Create new layer(s) for all modeling work through the Layer Property Manager To create/manage layers -> RC on any ACAD toolbar -> LC Layers -> On Layers
toolbar, LC Layer Property Manager icon (see Figure 4)

 

http://gmv.cast.uark.edu/wp-content/uploads/2011/05/clip_image0063.jpg


Figure 4 Layer Property Manager – Create and modify layers here. Layers are the primary means of controlling objects in ACAD and organized, clearly-named layers
are essential to managing the drawing.

Selecting Objects

Lines, blocks, solids, and other objects can be selected individually or in groups/sets.

Select Single Object > LC directly on the object.Â  It’s grips will highlight showing it has been selected > Use Shift + LC to select multiple grips

One or more objects > LC + move with the mouse to draw a selection window

If the selection window is drawn from left-to-right, only objects that are COMPLETELY ENCLOSED BY THE WINDOW are selected
If the window is drawn from right-to-left, every object that TOUCHES THE WINDOW is selected

De-select > LC + Re-selecting an object will de-select it from a set; ESCAPE will de-select the entire selection

Figure 5 – (Left) Selection Window drawn left-
to-right with start and end points marked. (Right) The grips (blue “dots”) of all objects selected are highlighted – Note the yellow rectangle in the lower right hand of the

screen; although the selection window touched the rectangle, it did not enclose it, therefore it is not selected

 

Figure 6 – (Left) Selection Window drawn right-to-left with start and end points marked. (Right) The grips (blue “dots”) of all objects selected are highlighted – Again,
note the yellow rectangle in the lower right hand of the screen; the selection window touched the box, therefore it is selected

 

Copying & Pasting Objects
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Objects may be copied and pasted within a single drawing or copied from one drawing and pasted into another. In all cases, when objects are copied a base point is
assigned. This base point is the “handle” of the copied object – you might think of it as the point at which the mouse is “holding onto” the object.

I. Copying Object(s) – clipboard

A. Select the object(s) to be copied

B. RC > Clipboard > Copy Options:

Copy = Objects are copied to the clipboard and a default base point is assigned; this base point’s location depends on how the object was created but it is often
located in the lower left-hand corner of the object(s)

Copy with base point = Objects are copied to the clipboard and the user assigns the base point, which is useful when placing the object accurately

Assigning a base point – the base point may be assigned to a point on the object or to a point in the coordinate system. Using a point on the object is useful
when you are trying to place objects and the coordinate system is not important. Using the coordinate system origin (0,0,0) is useful when copying object(s) from
one coordinate system to another or when objects do not provide accurate references.

Point on Object > LC on a point on the object to specify it as the base point

Point in Coordinate System > When prompted to specify a base point, manually enter coordinates in the command line (#,#,# – digits separated by commas and
NO spaces) > ENTER

NOTE: Copying by the origin point 0, 0, 0 (x=0, y=o, z=0) allows the user to paste by the same origin point; in this way, object(s) can be copied from one DWG and
can be pasted into the exact same location in a different DWG regardless of differing scales or coordinate systems

II. Pasting Object(s) – clipboard

A. Paste by base point on the object(s) > RC > Clipboard > Paste > LC to place the object – the point that you LC represents the location that the base point of the
copied object is placed

B. Paste by coordinates > RC > Clipboard > Paste options:

Paste to original coordinates = object is placed at the x, y, z coordinates of the original drawing that were defined as the base point by the user when the object
was copied

Paste = Command line prompts for insertion point:

Enter coordinates in the command line (#,#,# – digits separated by commas and NO spaces) > ENTER

LC at point in new drawing > object(s) are placed according to the point that you specified as the base point in the original drawing with this LC

C. Paste as Block > Object(s) are converted into a single block/entity upon pasting; this is useful when copying complex drawings to keep everything together

NOTE: Blocks are groups or components that exist within a single drawing or multiple drawings. When copied or inserted, they retain the characteristics of the
original block and when pasted, the block is placed on whatever layer is current; when one block is edited, all blocks are edited simultaneously.

NOTE: <EXPLODE> separates blocks into the individual, original objects (and their individual layers); when copying/placing multiple objects at the same time,
pasting them as blocks helps to keep multiple objects grouped and positioned correctly until they are adjusted/placed, at which point they can be exploded

III. Copying/pasting within a single drawing – command line

A. Select the object(s) to be copied > command line: <CO> or <COPY>

B. Object is copied and remains visible and command line prompts the user to specify the base point > LC on a point on the original object to specify the base point

C. Dragging the mouse, moves the object to the point where the copied object is to be placed > LC on the point you want to paste the base point of the object

]]> http://gmv.cast.uark.edu/modeling/software-visualization/autocadrevit/workflow/autocad-2009-interface-and-file-structure-basics-2/feed/ 0
http://gmv.cast.uark.edu/modeling/software-visualization/autocadrevit/workflow/leica-cloudworx-and-cad-workflow-for-modeling-between-programs-2/
http://gmv.cast.uark.edu/modeling/software-visualization/autocadrevit/workflow/leica-cloudworx-and-cad-workflow-for-modeling-between-programs-2/#comments Fri,
20 May 2011 23:21:52 +0000 caitlin 5 meters]]> http://gmv.cast.uark.edu/2726/leica-cloudworx-and-cad-workflow-for-modeling-between-programs/

In this series, columns in a deteriorating colonnade will be modeled by several methods.
Hint: You can click on any image to see a larger version.

IMPORTANT NOTE ON OBJECTS IN ACAD

IMPORTANT NOTE ON OBJECTS IN ACAD: When using the following methods (EXTRUDE, SWEEPT LOFT, REVOLVE) you can create solids or surfaces.
Whether the object is solid or surface is determined by 2 things:

(1) Whether the polyline is open or closed: Open polygons and curves always create surfaces but closed polylines and curves can create either.

(2) Which tab is active at the top of the ACAD workspace (See Figure 1) – If the Solid tab is active, a solid is created; if the Surface tab is active, a surface object
is created; if the Home tab is active, by default, a solid is created from closed polylines (this default can be changed once a command is active by entering ‘M’ for
Mode at the prompt) – Solids seem to translate into the COE format and import into Cyclone much better than surfaces, which sometimes will not show up in
Cyclone at all in the COE format.



Figure 1 – Main ACAD toolbar with modeling tabs highlighted in Magenta; EXTRUDE, LOFT, REVOLVE, AND SWEEP exist on each of the modeling tabs. Which tab is
active and whether the polyline is open or closed determines what type of object is created.

SET UP THE ACAD MODEL SPACE

I. Set up the ACAD Model Space

1. Configure/Open the Cyclone MSÂ  and set up the ACAD model space (See the GMV’s “Leica CloudWorx 4.2 and AutoCAD 2012 – Digitizing a Point Cloud in
2D” for more information)

2. Create Layers for each of the 3 slices and the final column object, making the bottom slice’s layer active

3. Adjust the object geometry association variable in CAD -> command line: DELOBJ > adjust to value zero

(NOTE: This number determines whether the original geometry used to create a 3D object – in this case polylines – are retained or deleted when the object is
created. This value can range from ’0' through ‘-3', with ’0' retaining all geometry and with ‘-3' deleting all defining geometry. Retaining geometry is
recommended for analysis and any possible back-tracking. Search “DELOBJ” in ACAD help for more information)

SETUP ACAD MODEL SPACE – CONT.

4. Hide Regions to isolate first feature to be modeled, in this case, the colonnade.

Figure 2 Top view of colonnade – roof and other un-needed data has been hidden with Hide Regions; colonnade (highlighted in the magenta rectangle) is easily
evaluated for complete/intact features

EXAMPLE

Method 1: Slicing Cross Sections and Lofting - Point Clouds may be sliced to view specific sections or profiles to model; these slices are made across the x, y, or z axis
based on the current UCS. Slicing large areas is useful when looking to see which features are the most intact/complete across a site. Slicing small areas allows for precise
drawing/modeling. In this method, a column will be sliced and the section’s profile (ie: cross sections) will be traced and lofted into solid or surface objects.

In the first example, the column is sliced 3 times on the y-axis. Tracing the slices creates 3 polylines representing the section cuts from the bottom, middle, and top
sections of the columns -> These cross sections will then be lofted to one another, forming the modeled column object.

USE THE CLOUDWORX SLICE TOOLBAR
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II. Use the CloudWorx Slice Toolbar  to slice the point cloud along the y-axis as the first section cut at the bottom of the column. Slices
can be made in several ways.Â  NOTE: a slice must be named in the Cutplane Manager (main Cloudworx toolbar) in order to be saved; if unnamed, it will be deleted
once it is deactivated!!!

1. Clip Point to Slice -> uses two parallel planes to define the slice; only those points between the two planes are shown > Command line: CWSLICE or Cloudworx
> Clip Point Cloud > Slice > Define Axis > LC in viewport to place 1st and 2nd clipping planes.Â  NOTE: Current Slice can be moved one step (equal to width of
the slice) forward (CWSLICEF) or backward (CWSLICEB) along its axis

CLIP POINTS TO SECTION

2. Clip Points to Section > uses single plane with only those points on one side of the plane visible > Command line: CWSECTION or Cloudworx > Clip Point
Cloud> Section View > LC in viewport to define axis and direction (positive or negative)

Figure 3 – (Left) Hide Regions command has isolated colonn cut; (Right) Sliced colonnade – note the points are not deleted, simply hidden ade – Clip-to-Slice command
(slices shown by magenta lines) creates the first section

TRACE AND SNAP TO POINT CLOUD

3. Trace first section cut, snapping directly to point cloud > Top View > Make correct layer current > Zoom in to view points comfortably and refresh point

cloud to confirm all points visible  (do this periodically, especially when zooming in/out) >Command Line: PL or POLYLINE to trace the profile/outline
of the bottom slice of the column

REMEMBER: (1) Enable OSNAP “NODE” to snap to points (2) At command line: type “U” during active polyline command to undo vertices/go back
without ending the command (3) At command line: PEDIT allows polyline(s) to be edited, joined, etc. (4) See ACAD Help: Drawing and Editing Polylines
for more information

3A. Repeat Steps to create the polylines for the remaining section cuts (note you may create more or less slices as desired – a higher number of slices and/or
increased complexity results in a more accurate tracing but also requires a higher and more difficult set of calculations to loft/join the separate sections; when too
complex, the lofting command may fail to calculate the final object as desired) > Confirm each section is made of only one polyline (use PEDIT -> JOIN and
PEDIT -> CLOSE to join and close multiple polylines)

3B. Once all section cuts are traced, hide the visibility of the point cloud  -> make the column object layer current

3D MODELING MAIN TOOLBAR

III. 3D Modeling main toolbar > EXTRUDE tab pulls down to LOFT (see figure 4) or at command line: LOFT > Select cross sections in the order they are to be lofted
to one another (here from bottom to top) > ENTER after selection > ENTER a 2nd time to accept “Cross Sections Only”

Figure 4 Extrude icon pulls down to reveal Loft and Revolve Icons in the 3D Modeling Workspace or enter LOFT at command line
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RETURN TO ORIGINAL COORDINATES AND EXPORT

IV. Return to Original Coordinates and export > If you have altered the Coordinate System, return it to the World Coordinate System that matches the original scan
world coordinates (See the section: ‘Setting up a Model Space in AutoCAD: Using User-defined coordinate systems’ and Figure 4 for more information) > Modeled object
can now be edited or exported as desired > Select objects > File > Export

TIPS FOR LOFTING

TIPS for lofting: Attempting to loft more than 2 complex cross sections, such as highly detailed tracing, may freeze the program or take large amounts of time. If this
happens, try lofting 2 polylines at a time to create separate objects and then grouping or converting these separate objects into a single surface or solid object as needed.
Retaining the original geometry (ie: the polylines through DELOBJ) and using layers is essential to dividing the lofting command into manageable pieces; to join multiple
objects -> NOTE: although multiple objects can be joined together into a single object with the UNION command, objects that have been united do not seem to translate
into COE files well; if you have used the UNION command and find importing the COE file into Cyclone is slow or unsuccessful, try the original objects, pre-UNION
(this is another case in which retaining your original geometry is very helpful).

Figure 5 (Left) Each section cut has been traced as one polyline and the point cloud is hidden; 1st the bottom polyline and 2nd, the middle polyline are selected for lofting
(the magenta arrow highlights the order of selection and lofting direction) (Right) 2 polylines create the first lofted object (ie: the bottom of the column)

EXAMPLES OF LOFTING

Figure 6 (Left) The column has been completely lofted into 2 objects (in white) and the original polyline geometry is still present and visible (blue and gray circles) –
(Right) UNION has combined the 2 pieces of the column and the point cloud’s visibility is turned on for comparison
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