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This series will show you advanced modeling building modeling techniques using Leica’s Cyclone.
Hint: You can click on any image to see a larger version.
As objects become more complex, using layers (Shift + L) becomes essential to organizing and controlling the model
space.

CHOOSE YOUR MODELING METHOD
As noted, it is best to model features in individual ModelSpaces, re-inserting them into the original ModelSpace
upon completion. Often features, such as windows, will repeat on structures or sites. Whether each feature is
modeled individually or modeled once and then repeated depends on the discretion of the user and the nature
of the subject. New, modern structures (such as office buildings) are well-suited to modeling features once and
repeating them as they often utilize standardized materials and building methods. Older and/or deteriorating
structures/sites are better-suited to modeling features individually as time, movement, and building methods
often result in more organic, unique features. As always, the method of modeling depends on the subject and
the user’s intentions.

COPY WORKING AREA
1. Copy working area to new Working ModelSpace (for example, you may be modeling an entire building
but at the current stage, you are inserting a repeating window into a wall; in this case, copy the wall to a
Working ModelSpace and model individual windows in a Feature Modelspace. These temporary modeling
spaces will be re-inserted into the overall building model later)
2. In Working ModelSpace, create base model in which to insert repeating feature (in this example, create the
wall) -> Place on its own layer -> Insert Copy of Object’s Points
3. Within Feature ModelSpace (MS where window is modeled) -> Select all objects making up feature ->
Edit -> Group -> Copy -> Close Feature MS (do not merge into original!)

ASSIGN GROUP TO ITS OWN LAYER
4. Within Working ModelSpace (MS where larger wall has been copied) -> Paste -> Assign Group to its own
layer
Note: As long as the coordinate systems have not been altered, the feature will paste into the correct location
within the Working ModelSpace. This original feature will be the only copy whose location is directly linked
to the point cloud data at this point. When the feature is subsequently copied and placed within the working
ModelSpace, accuracy to the original data is dependent on how copies are placed by the user and how the
points are used/referenced in placement.

Figure 15 – (Left) Complex feature is grouped and copied (Right) Feature is pasted into the working ModelSpace – note that the feature inserts into the correct
position based on the original scan data

DEFINE A “COOKIE CUTTER”
5. If the repeating feature requires a repeating opening, draw a polyline on top of the inserted group to define the
opening (this polyline will be used as a “cookie cutter” to make subsequent openings in the wall surface; polyline
opening should be slightly smaller than the feature to be inserted -> Place cookie cutter polyline on its own layer
6. Use polyline to create opening in primary (wall) patch (follow steps for “Creating Repeating, Identical
Openings“) -> this opening now reveals the grouped window within the primary wall surface

Figure 16 – The large magenta rectangle highlights the entire group; the yellow polyline (representing the “cookie
cutter” used to create openings in the primary surface) is slightly smaller than the group

Figure 17 – Opening has been made and the grouped window is revealed – note the yellow polyline “cookie cutter”
and the group can be copied and repeated on the primary wall patch
7. Select the Window Group and the “cookie cutter” polyline -> Copy to the next location; there are several
methods for placing the repeating feature; two possibilities are outlined below, however different options can be
mixed/matched:
7A. Copying and Locating by Pick Points > Multi-select 1st) Group/window 2nd) cookie cutter polyline 3rd)
Point representing location where copied object is to be placed -> Create Object -> Copy
7B. Copy dialogue box appears and points that have been chosen are numbered -> Direction of Move, click on
blue arrow -> Point to point, define points to use for direction of move and ok -> Distance of move, click on blue
arrow -> Point to point, define points to use for distance and ok -> At main dialogue, confirm objects are correctly
identified in the “Apply To” pull-down menu -> Copy
Note: If pick points do not show up correctly when copy dialogue box appears, you can re-define pick points
while copy command is active; simply multi-select new pick points before defining direction and distance

Figure 18 – Window Group and Polyline are copied with Cyclone’s green arrow showing direction of copy – note that
in this case, both the direction and the distance of the copy are from Point 7 to Point 8

MULTIPLE COPIES BY DISTANCE AND AXIS
7C. Multiple Copies by Distance and Axis > Multi-select points representing 1st) the starting location of the
object to be copied 2nd) the offset distance the object will be copied to -> Tools -> Measure -> Distance -> Point
to Point -> Annotation showing distance appears
7D. Continue multi-select command -> Select Object(s) to be copied -> Create Object -> Copy -> Direction of
Move -> Choose Axis and ok (arrow appears showing which axis will be used for the copy – note that the
direction copy is placed along axis is defined by a positive or negative number in the distance)
7E. Distance of move -> Custom -> Enter amount derived with measure command and ok (a negative or positive
possible determines the direction on axis) >Main Copy Dialogue box -> Enter Number of copies – note that copies
will be offset from each succeeding copy, NOT from the original start location -> Confirm command applied to
objects correctly -> Copy
NOTE: Any error will increase as distance increases; therefore it’s important that you examine each copy for
accuracy and manually adjust as needed, especially those copies at the greatest distance from the original

Figure 19 – Multiple copies (highlighted in magenta) are offset from one another; openings can be seen in the green,
point cloud data – note that as distance increases from the original left group, the error between the proposed
opening/group and the accurate opening in the point data also increases and must be adjusted

REFINING THE PLACEMENT OF REPEATING FEATURES
8. Refining the placement of Repeating Features – as noted, small errors in distance increase with
repetition/distance. Using the point cloud and the constraints in Cyclone are essential to accurately placing and
locating features. In this example, the primary patch (the wall) is located along the x-axis. As succeeding windows
become mis-aligned with the actual point cloud openings, windows are adjusted individually to rectify the model with
the point data.
For distance moved, specific points are used – in this case the window sill protruded creating a discernible corner
to match with the model’s sill corner.
Direction moved is restricted to the x-axis – this ensures that (1) the succeeding windows stay horizontally
aligned with the original and (2) all windows stay along the same plane (the main wall where original window was
placed).
Note: Surfaces are very rarely perfectly orthogonal and flat; rather they usually have fluctuations and they deviate
from perfect angles. As such, when comparing a flat surface that has been modeled to the point cloud data, points
should appear dispersed on both sides of the plane/patch; all points should not be completely located on one side
or the other as this indicates the plane is not directly referencing the points.

Figure 20 – (Left) A window is misaligned with the point cloud data; zooming in allows the user to use the points very
precisely; movement by picking points allows accurate placement of specific features, such as corners, while moving
by a standard axis allows orthogonal alignment with other objects, planes, and references (Right) Window is rectified
with the x-axis and specific points on the window sill. Note that the visibility of the primary patch (the main wall) has
been turned off for clarity of other layers.

MISSING DATA AND COMBINING RESOURCES
9. Missing data and combining resources – While point cloud data and axes help accurately place most features, in
some cases data is simply not present. In these cases, utilizing other resources is essential to creating a complete model
that is as accurate as possible. In this example, a tree left a large shadow in the wall and placing windows within this
shadow becomes difficult with point cloud data alone.
Utilizing measurements – finding the average distance between other windows and placing the windows in
shadow at this offset helps place the windows fairly accurately.
Comparing the model with the photographic data collected during scanning further assists in accuracy.

CREATE OPENINGS IN PRIMARY WALL PATCH
10. Once each group has been evaluated and placed accurately -> use the cookie cutter polyline to create openings
in the primary wall patch as shown in Step 5 of this section -> Erase or hide the polylines as needed once used (erase
if merging back into the original ModelSpace and lines are no longer needed; hidden if copying into original
ModelSpace and you want to maintain reference objects in the working ModelSpace).

Figure 21 – (Left) Windows, in dark blue, have been individually analyzed and adjusted for accuracy with the point

cloud, in green (Right) Openings have been made in the primary wall patch, in light blue; the dark blue window
groups are revealed.
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This series will show you advanced modeling building modeling techniques using Leica’s Cyclone.
Hint: You can click on any image to see a larger version.
As objects become more complex, using layers (Shift + L) becomes essential to organizing and controlling the model
space.

MODELING AN ANGLED WINDOW OPENING
A. Modeling a Complex Shape – An Angled Window Opening
1. Copy area to be modeled into new, working ModelSpace
2. Familiarize yourself with the object and the different layers/depths in space that you are working with; when
angles are involved it’s good to understand where each angle terminates.

Figure 8 (Left) Complex window to be modeled (Right) Familiarize yourself with the layers of space to be modeled –
here yellow represents the farthest plane (the glass) and orange represents the closest plane (the wall in which the
window is set)

DIVIDE INTO SUB-SELECTIONS IF NESSCEARY
3. It may be useful to divide the point cloud into sub-selections based on their depth in space or on separate areas
to model – Rotate the object to view it from the side or top view -> fence the area to be subselected -> RC ->

Point Cloud Subselection -> Add Inside Fence

Figure 9 – Point cloud is sub-selected into several clouds based on their depth in space

MODEL THE OBJECT
4. Model the object using patches, extensions and extrusions as previously outlined – when modeling angled or
complex surfaces, patches can be created several ways. When fencing an area and fitting a patch, fence the area
that best represents the surface – exclude areas where the surface becomes skewed or extreme near boundaries,
curves, etc.
5. While snapping adjacent patches together and extending them, extra handles are often created. It’s best to
clean up the patches as you go of any extra handles/geometries to maintain simple, clean lines where possible:
Select Patch -> ALT + RC on extra handle -> handle removed

Figure 10 – (Left) Extra handles have been
created where the patches intersect (Right) Extra handles deleted, leaving the cleanest, simplest geometry possible

MODELING TIPS

6. As objects become more complex and angles become more complicated, it may be helpful to visually clarify
and define the objects. This can be done several ways, including editing object colors and creating lines along the
edges of objects that are intersecting. Lines create crisp edges and create wireframe objects for export later.
6A. Change Object Color -> Select Object -> Edit Object -> Appearance -> Choose color
6B. Creating Lines where objects intersect: Once the patches/objects have been extended to one another >
Mult-select 2 intersecting patches -> Create Object -> From Intersections -> Curve (Note that in Cyclone, a
curve here is a line. Also note that sometimes lines will extend beyond the object. Select the line -> slide the
handles so beginning and end of line is within the object -> use handles or extend command to make the lines
form corners) NOTE: It’s recommended to place lines/polylines on their own layer to aid in there
selection and visibility later.

MORE MODELING TIPS
7. While modeling complex objects, you will encounter areas where surfaces exist but there is no point cloud
data to model directly from. Extruding and extending will often produce these surfaces but sometimes creating
polylines and customized patches may be the best way to model these areas. Using the handles of previously
modeled objects helps maintain the accuracy of the scan data.
7A. Align view to see the vertices of existing objects to use as guides for the edges of the proposed patch.
7B. Choose handles/points to create the new patch – select the points in the order you wish to draw the
polyline that will define the edges for the patch. Do not close the polyline, leaving the last line segment open.
7C. Create Object -> From Pick Points -> Polyline -> Assign Polyline to its own layer
7D. Create Object -> From Curves -> Patch

Figure 11 – (Left) Objects have been created from point cloud however no data exists for the area inside the red
rectangle (Right) Handles of the previously modeled objects are used as pick points to
define the edges of the custom patch – note that the final side of the polygon is left open

Figure 12 – Polyline that was formed from pick points is used to create new custom patch

GROUPING
Helpful Hints Grouping: Whether repeating a complex feature or using it only once, it’s a good idea to group the various
objects together to maintain the integrity of the individual objects and their intersections. Both small and large
ScanWorlds can be best controlled through:
(1) Copying specific areas to a new ModelSpace to model individually > Fence > RC > Copy to new
MS
(2) Grouping complex features after they are modeled > Select All Objects that compose complex feature > Edit -> Group
NOTE: Select all objects, NOT points in the grouping; Items may be ungrouped and removed from groups
through the same command

HINT – VISIBILITY AND SELECTABLITLY
Hints
Visibility and Selectability – As complexity increases the use of layers becomes crucial. You can control which layers
are visible and selectable in the layers dialogue box during an active command; this becomes very useful as points,
objects, and lines become placed on top of one another)

Figure 13 – Magenta highlights the column showing whether layer is visible; yellow highlights the column showing
whether layer is selectable – these attributes can be toggled as needed during active commands

HINT – ACTIVE COMMAND
Hints
Active Command Dialogue – The command dialogue at the bottom of the screen is also very useful as models
become more complex. It lists everything that is selected (line, point cloud, group, etc), and as each item is selected,
the dialogue shows the layer of and the specific coordinates of each

Figure 14 – The dialogue line at the bottom, left of the screen shows information about the items that are actively
selected.

HINT – EXPLODE COMMAND
Hints

Explode Command - When a volumetric object is used or when a patch is exploded, it may be necessary to break the
volume into individual planes -> Select Object -> Create Object -> Explode

CONTINUE TO…
Continue to Modeling and Placing Repeating Features
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This series will show you advanced modeling building modeling techniques using Leica’s Cyclone.
Hint: You can click on any image to see a larger version.

SELECT OBJECT
Note that restoring the original points that are removed when an object is created is essential to placing
openings or to creating more complex features within an object.
I. Select Object –> Right Click –> Insert Copy of Object’s Points. Also note that if/when the working ModelSpace
is merged back into the original ModelSpace upon closing, all objects and points are merged so any re-inserted points
should be considered (most likely deleted) before merging into the original MS.

II. Once the points have been inserted, Align View so that object being modeled is perpendicular to screen (see
GMV Guide ‘Model a Non Rectangular Patch’). There are several methods to creating openings, depending on their
geometry and whether the opening is repeated:

CREATING A SINGLE OPENING
A. Creating A Single Opening:
1. Create primary patch/wall in which hole is to to be made
2. Select Object –> Right Click –> Insert Copy of Object’s Points.
3. Create Fence that is completely inside intended opening
4. Select the primary patch -> Edit Object -> Patch -> Subtract

Figure 5 (Left) Primary Patch with copy of points inserted and fence drawn- note the fence for the proposed opening is
completely within the patch; (Right) Fenced area subtracted from primary patch

CREATING AND REPEATING IDENTICAL OPENINGS
Â B. Workflow for Creating Repeating, Identical Openings:
1. Create primary patch/wall in which opening is to to be made
2. Select Object –> Right Click –> Insert Copy of Object’s Points.
3. Multi-select points to outline the intended opening -> Create Objects -> From Pick Points -> Polyline
(Recommendation: Assign this polyline to a new layer to make it easier to use later)
4. RC -> Fence -> From Selection
5. Select Primary Patch -> Edit Object -> Patch -> Subtract
6. Select Polyline -> Select handle + CTRL to move to next location -> Repeat Steps 1-6 (Note the polyline can
be edited by using the handles if succeeding openings differ)

Figure 6 Polyline is created from points and placed on its own layer on the first of a series of identical openings

EXAMPLE

Figure 7 (Left) First opening has been subtracted from the primary patch and the polyline has been moved to the
second proposed opening; (Right) Identical second opening has been subtracted
]]> http://gmv.cast.uark.edu/uncategorized/leica-cyclone-7-0-advanced-guide-for-building-modeling-modelingopenings-in-objects-2/feed/ 0 http://gmv.cast.uark.edu/uncategorized/leica-cyclone-creating-a-mesh-and-modelingsurface-topography-creating-the-topographic-mesh/ http://gmv.cast.uark.edu/uncategorized/leica-cyclone-creating-amesh-and-modeling-surface-topography-creating-the-topographic-mesh/#comments Tue, 10 Apr 2012 18:01:07 +0000
caitlin 5 meters]]> http://gmv.cast.uark.edu/?p=6186
This series will show you how create a mesh and model surface topography in Leica’s Cyclone
Hint: You can click on any image to see a larger version.

SELECT POINTS
9. Select Points (when dealing with large areas, selecting several points results in more surface points being sampled
in the surface growing process) -> Create Object -> Region Grow -> Smooth Surface -> Cyclone runs the region grow
by default settings to show the initial view and the dialogue box – Adjust Surface Characteristics and click ‘Restart’ to
preview results -> Click OK when satisified with preview:
Hardtop Surface (this is generally chosen for fairly uniform areas with paved or hard surfaces; if dealing with
rolling unpaved terrain, uncheck this option).Viewing the point cloud with color from scanner or hue intensity is
recommended for this process Per Cyclone 7.0 Glossary: “This command is used to segment a selected smooth
surface in a point cloud. The points representing the smooth surface are merely segmented from the point cloud;
no object is inserted. This command is not available for use with a pcE file (pcE cloud).”

DECIMATE AND SUBDIVIDE
10. Decimate Mesh (per Leica Trainer July 2010 current bug in meshing command) -> Select Mesh -> Tools -> Mesh
-> Decimate -> Maintain 100% of original triangles, vertices, and exact boundary edges -> Decimate allows pre-view
-> OK to accept
11. Subdivide areas by breaklines -> Select Boundary Breaklines and Mesh -> Tools -> Breaklines -> Extend
Polylines to TIN -> (NOTE: This command extends a polyline onto a TIN ojbect, creating edges in the mesh based on
the projection of the polyline vertically onto the mesh – although polyline itself does not change. The edges are

stretched vertically to conform to the polyline’s shape – If select command through Breaklines submenu, polyline will
be converted to breakline on the mesh; if select command through polyline submenu, resulting line will be a geometric
object
NOTE: If errors appear 1) Select Mesh -> Tools -> Mesh -> Verify TIN -> If TIN is not valid, the number
of invalid faces will be listed and the faces will be selected -> Tools -> Mesh -> Delete Selection -> Repeat this
verfication and deletion process until TIN successfully verified; (2) If errors regarding polylines overlapping ->
Select Polylines -> Tools -> Drawing -> Align vertices to axes

ADDITIONAL STEPS
12. Re-insert break lines (copied in Step V) -> Copy from temporary location -> Paste into working mesh MS
13.Â Editing Triangles and Spikes -> In layers dialogue box -> View As tab -> Apply to Mesh -> Wireframe ->
Apply & OK ->
14.Â In top view, fence in problematic triangle(s) causing spike -> Fence -> Delete Inside -> Select hole
(highlights cyan) -> RC -> Mesh -> Fill selected hole

EXPORTING
15. Exporting 3D Lines, Mesh, Point Cloud -> There are several options for exporting topographic features.The
objects created through tracing and meshing can be exported or the point cloud itself can be exported.
A. Export the lines, polylines, arcs -> Use the properties manager (Shift + L) to turn off the
visibility/selectability of the point cloud -> Select All -> File -> Export
DXF R12 Format â€“This retains 3D information (in this case the z-coordinate for the lines); Do
not select 2D DXF R12 Format
Objects may also be exported as ASCII or XML file types here
Once exported, the .dxf file can be opened in CAD, imported into Sketchup, or converted for use in
multiple software.
B. Export the mesh -> Select mesh -> File -> Export -> Select file type for destination software
C.Â Export the Point Cloud -> Newer versions of Autodesk products (2009 and beyond) support point
clouds.If you do not have Cyclone but you do have CAD, use Cyclone to export the points and then
trace/model in CAD software much as we have done in Cyclone.The main issue is file size when importing
into CAD; in general, point clouds must be broken into smaller pieces to allow them to be imported.See the
CAST workflow, ‘Reducing Point Clouds for Autodesk Applications’ for more details.
NOTE: In general, a .PTS file with a maximum size of 4mb will import into CAD
Create new layers for the breaklines and features (Shift + L) -> Review the area to be modeled identifying where the
surface changes and/or where the user wants a clean break or difference between adjacent surfaces.Create layers for primary
and secondary features as needed.
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This workflow will show you how to use Leica’s COE plug-in to import and export objects and points in
Cyclone.
Hint: You can click on any image to see a larger version.

IMPORTING & EXPORTING

Importing & Exporting Objects and Points in Cyclone with COE Files
I. Importing files into Cyclone is done through the Navigator window, where a new MS is created with the imported
file -> Open Cyclone Navigator -> Select Database/ModelSpaces Folder -> RC -> Import -> browse to COE file ->
Open -> MS View appears named by default with the COE file location
NOTE: You cannot import a COE into a MS view, rather it must be imported into the overall “ModelSpaces”
project folder at which time a new MS view is created for editing.Â While most objects can be imported into
Cyclone, complex objects (ie: beveled edges, rounded corners, notches) may be translated into a collection of
lines and arcs versus objects when imported

MANAGING THE COE-MS
II. Managing the COE-MS -> Open the COE ModelSpace that has automatically been created -> It is recommended
that you group objects and place them on individual layers as needed in this original COE MS (to group -> Select
Objects -> Edit -> Group -> Group -> Objects can be ungrouped at any time with this command as well) -> Copy all
objects -> Close COE MS

PASTING COE OBJECTS INTO ORIGINAL MS
III. Pasting COE objects into Original MS -> Its highly recommended to copy and paste the original MS as a
copied/working MS in Cyclone Navigator; use this copied MS to insert objects, updating the original MS only as a
final step -> Open copied MS -> Paste objects that were copied from COE file in Step II -> NOTE: if coordinates
were maintained and referenced throughout the modeling and export process, the object should automatically paste
into the correct position. If references/links have been lost, the imported objects may need to be moved/rotated (select
objects -> RC -> move/rotate)
NOTE: When moving grouped or multiple objects, faces and lines may appear to remain in their original position
or become displaced during manipulation; as long as all objects are selected or grouped/selected, this is only a
refreshing issue -> View Properties (Shift + L) -> Selectable/Visible Tab -> toggle the visibility of the object type
off (ie: mesh or patch, etc) and when toggled back on, the view of all objects should be refreshed.

COMPARING MODELED OBJECTS WITH ORIGINAL POINTS

Comparing Modeled Objects with Original Points in Cyclone
I. Import the COE file into Cyclone Navigator

II. Upon importing, the COE creates its own MS that loses many of the editing/manipulation options -> Open the
COE MS -> Select All -> Copy -> Open Working MS (containing points to compare/analyze) -> Paste COE object(s)
into Working MS; NOTE: Pay attention to the layers in Cyclone: all ACAD layers accompany the object when
imported however when copied/pasted objects are placed on a layer named ‘default~’; Manually assign the correct
layer to the object in the Working MS and delete unnecessary layers.

CALCULATE MESH TO POINT CLOUD DEVIATION
III. Calculate Mesh to Point Cloud Deviation -> Multi-select the object mesh and the point cloud (Its recommended
to view the mesh in “per-face normals” setting > Shift + L for Layers > View As tab) -> Tools -> Measure -> Mesh
to Points Deviation -> Dialogue Box Options:
Slider bar allows user to adjust and preview deviations on the mesh faces above a user-set limit; minimum and
maximum boxes are read-only
Distance computation – user decides whether those faces that are highlighted are based on maximum or average
deviation and Absolute (no positive/negative distances) or Signed Distance
Details – displays total mesh faces, # of faces deviating, what percentage of the whole that represents, and total #
of points

CALCULATING DEVIATION – CONT.
IV. Calculate Object to Point Cloud Deviation when Object is created in Cyclone > Object (ie: cylinder,
primitives) -> after creation, select object and RC -> Info dialogue tells Fit Quality including Error Mean, Error Std.
Deviation, and Absolute Errors; Interfering Points may also be calculated
V. Calculate Object to Point Cloud Deviation when Object is created outside of Cyclone -> Interfering Points ->
Multi-select object and point cloud -> Tools -> Measure -> Interfering Points -> Dialogue box appears in which user
can adjust the tolerance to calculate -> all cloud points that are within the user-specified distance of the selected object
are highlighted and can be segmented from the rest of the cloud (See Cyclone help ‘How to Segment interfering
points’ for more details) and dialogue box displays the percentage of points interfering and the percentage of points
inside the object (useful in volumes); this analysis is limited in many modeling applications as accurately modeled
objects rarely lie completely on one side of the points referenced
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In this series, columns in a deteriorating colonnade will be modeled by several methods.
Hint: You can click on any image to see a larger version.

CLOUDWORX

Comparing Modeled Objects to Original Points in this example
(analyzed at .005 m (.5 cm) / average distance of deviation/ absolute value)

I. CloudWorx – three section cuts in the x or y direction – lofted in the z (up) direction to

create 3D solid column:
Â· 7% of the mesh faces (ie: 484 of 6,914) were above .5 cm deviation from point cloud

CLOUDWORX 2
II. Cloudworx – 1 section cut in the z direction (representing 1/2 the column from outside
edge to center) – revolved around center axis to create 3D solid column
Â· 43% of the mesh faces (ie: 6,055 of 14,160) were above the .5 cm deviation from point cloud

CYCLONE
III. Cyclone – Mesh created in Cyclone from point cloud
Â· < 1% of the mesh faces (ie: 977 of 334,133) were above the .5 cm deviation from point cloud
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In this series, columns in a deteriorating colonnade will be modeled by several methods.
Hint: You can click on any image to see a larger version.

USE THE CLOUDWORX SLICE TOOLBAR
Method 2: Slicing Single Cross Section and Revolving the Profile Around Center – Similar to the first method, the
column will be sliced and traced; however here, a single profile will be traced and revolved around the center, creating
a solid or surface object.Â Follow steps in Method 1, Section I for setting up the ACAD model space and isolating the
colonnade.
I. Use the CloudWorx Slice Toolbar to slice the point cloud from the top view (or whichever view allows you to
see the entire diameter of the column/feature); this will be the only section profile that will be traced and we will
only be tracing half of it; choosing the most complete/intact slice possible is recommended. See Method 1 for
details on slicing

Figure 7 (Left) Top view of the column; magenta lines highlight the slicing boundaries – (Center) Top view of the
column profile slice – (Right) Front view of the column profile slice

TRACE THE PROFILE AND SNAP TO POINT CLOUD
II. Trace the profile of the section cut, snapping directly to point cloud > Front or Side View > Make correct
(do
layer current > Zoom in to view points comfortably and refresh point cloud to confirm all points visible
this periodically, especially when zooming in/out) > Command Line: PL or POLYLINE and begin to trace the
profile/outline the profile of the section cut
REMEMBER: (1) Enable OSNAP “NODE” to snap to points (2) At command line: type “U” during active
polyline command to undo vertices/go back without ending the command (3) At command line: PEDIT
allows polyline(s) to be edited, joined, etc. (4) See ACAD Help: Drawing and Editing Polylines for more
information

DETERMINE CENTER AROUND WHICH TO ROTATE
III. Determine the center around which to rotate > NOTE: there are a variety of ways to determine the center of a
feature; one is outlined here. Also see the “fit pipe to cloud” method (following section), which determines the center
directly from the point cloud and places a polyline along the centerline >
A. After half of the profile has been traced turn on ORTHO mode, which restricts drawing to a
90-degree vertical and horizontal direction to ensure clean angles for the rotation later

B. OSNAPS – enable ENDPOINT and MIDPOINT -> Use ONSNAPS to draw a line that is
perpendicular to the column’s profile polyline: the start point snaps to the endpoint of the top of
the column and the end point snaps to the point cloud on the opposite edge of the section cut –
this line represents the full diameter of the column. Draw another line in the same way at the
bottom of the column (See Figures 12 & 13)

Figure 8 (Left) Front view of point cloud and polyline representing left profile of the column – (Center) Front view
with the point cloud hidden – (Right) Original polyline with perpendicular lines drawn at the top and bottom
representing the diameter of the column

EXAMPLES

Figure 9 -Â Front view, close-up of the top of the column; on the left of the image, the yellow polyline is the original
line tracing the point cloud profile (dense green points). With osnaps, draw a line snapping to the end point of the
original polyline. Ortho Mode ensures a perpendicular line to the opposite edge of the point cloud/column (less dense
green dots on the right side of the image). Repeat this process at the bottom to achieve the 3 lines shown in Figure 8.

USING OSNAPS
C. Use OSNAPS to snap to the midpoint of the line at the top of the column to the midpoint
of the line at the bottom of the column – this line represents the center of the column (TIP:
When snapping to midpoint, a triangle and the word “midpoint” appears near the cursor) -> Use
grips or the TRIM command to trim the ends of the lines that protrude past the center line

NOTE: This method finds the center based on the diameter of the column at the top and bottom
at the point of the slice, accounting for any leaning/tilting along the z-direction; For generally
upright features, drawing a line in the center and restricting it to the z-axis will result in more
regularized features with identical “up directions”
IV. Command line: PEDIT to edit the polylines and join them into a single closed polyline > PEDIT > Select
original polyline > JOIN > Select centerline, top line, and bottom line > ENTER 2X > Clicking on the polyline
should confirm that it is now a single object (if it does not join, check to confirm no endpoints are snapped to one
another but they are NOT overlapping).

Figure 10 (Left) Draw a polyline from the midpoint of the top line to the midpoint of the bottom line – note the yellow
triangle and ‘midpoint’ showing the OSNAP constraint is active (Right) Polylines have been drawn, trimmed, and
joined to form a single polyline representing the profile of the column from the center to the edge

ROTATE PROFILE TO FORM 3D OBJECT
V. Rotate profile to form 3D object > Create and make a separate layer for the 3D object and make it active > 3D
Modeling main toolbar > EXTRUDE tab pulls down to REVOLVE (see figure 4) or at command line: REVOLVE >
select profile polyline > ENTER > “Specify Start point or define axis” > Select endpoint at the bottom of the
centerline > “Specify axis endpoint” > Select endpoint at the top of the centerline > “Specify angle of revolution” >
ENTER to accept default of 360-degrees

Figure 11 (Left) The centerline of the column is drawn by snapping from the midpoint of the bottom polyline to the
midpoint of the top polyline (Right) 2D tracing of the point cloud section cut is revolved around the centerline creating
3D object
6. Modeled object can now be edited or exported as desired.
[wptitle]CONTINUE TO…
Continue to Comparing Modeled Objects to Original Points
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This series will show you how create a mesh and model surface topography in Leica’s Cyclone
Hint: You can click on any image to see a larger version.

INTRODUCTION AND DEFINITIONS
In this guide, a mesh is considered to be a series of triangles that represents a surface. Cyclone generates meshes by
using the points in a point cloud, vertices, polylines, or any combination of the three as vertices. For each adjacent trio
of points in a cloud, a triangle is created. This has the effect of creating a visually coherent surface from the point
cloud, and it is the primary method for modeling topography.
Break lines are lines or polylines that sub-divide the mesh; they represent the edges of a paved surface, a ridge, a
channel, or any other topographic feature that the user wants to preserve.Â While mentioned in 2D topographic
tracing, break lines become very important in meshing.Â Here, they have an accurate z-coordinate and they become
the edges that the triangles in the mesh conform to, defining and controlling the smoothness and continuity of the

mesh. They allow the user to break-up the mesh into reasonable “chunks” for future texturing and detailing.
Please see ‘Leica Cyclone â€“ Creating aÂ BasicÂ CAD OjectsÂ FromÂ Surface Topography (2D)’ as a supplement
to this workflow.

OPEN A REGISTERED UNIFIED MODEL SPACE
1. Open a Registered Unified Model Space -> Create fence around ground plane –> Right Click –> Copy Fenced to
new Model Space (NOTE: viewing from a standard side, front, or back view in orthographic mode assists in selection)
-> Original MS may be closed

Figure 1 – (Left) Original registered scan world of plaza (Right) Point Cloud Sub-Selection (Select -> Right Click ->
Point Cloud Sub-Selection) allows unneeded points, such as trees and vertical surfaces, to be deleted; Sub-selection
allows the user to precisely choose and view points before deciding to delete

SELECT AND DELETE UNNEEDED POINTS
2. In the new Working MS -> Select and delete unneeded points (it’s best to eliminate as much vertical surface data
as possible so that the ground plane to be modeled is isolated; objects in motion, such as trees/vegetation can be
especially problematic and cleaning up areas where these are abundant is suggested; eliminating data that may be
present inside buildings or areas that will not be modeled is also suggested)

Figure 2 – The same plaza as Figure 1 now copied to a working MS and “cleaned” of unneeded vertical surfaces and
vegetation leaving only the ground plane to be modeled.

CREATE NEW LAYERS FOR THE BREAKLINES AND FEATURES
3. Create new layers for the breaklines and features (Shift + L) -> Review the area to be modeled identifying
where the surface changes and/or where the user wants a clean break or difference between adjacent surfaces.Create
layers for primary and secondary features as needed.
4. Create lines to represent the topography and features, assigning an accurate x, y, and z coordinate -> There are
several ways to make lines including (1) using 2D drawing methods (covered in ‘Topography and Site Elements – 2D’
above) (2) with pick points, (3) by extending an existing line (4) by snapping two existing lines together (5) by creating
a polyline with Fit Edge command, and (6) by merging polylines together.
See Help -> Contents -> Search -> ‘Make Lines, Polylines, and Breaklines’ for steps for each of these
methods.There are additional variations of each.BEWARE: Lines created by pick points cannot be used for break
lines in meshing; if picking points, be sure to create a polyline rather than a line segment.

TIPS
5. Tips
A.Â If drawn in 2D, use Edit Object -> Move/Rotate to move the object to the correct z-coordinate; there are
multiple options moving objects including by a standard axis and pick points.
B.Â Create additional break lines following the feature or edge of the break lines; place these to break up the
mesh and around the boundaries, segmenting out areas where a topographic ground plane is not needed (ie:
inside buildings)

Figure 3 – Top view of plaza; Polylines have been created to outline where the sidewalk and grass meet; orange handles help highlight the polylines

MORE TIPS
More Tips:
C.Â Use multiple views to confirm line is properly located at all angles and handle constraints (Edit Object > Handles constrain to -> Various options – NOTE: once placed in top view, constraining handles to zdirection helps placement in 3D)
D. Try different methods to see what works for you.With all, use multiple views to confirm the line is
properly located at all angles

Figure 4 – (Left) Although from Top View, the breakline looks correct, inspection from a different angle reveals that it is not correct (Right) Handles and
constraints (Edit Object -> Handles -> Constrain Motion) are used to pull the polyline into the correct position – every section of every breakline should be
inspected from multiple views

FINAL STEPS

6. Create handles at places where polylines intersect (Select line -> ALT + Select point on line for new handle to
help snap lines together).
7. Delete all points beyond boundary of mesh -> Select polyline representing boudary of mesh -> Right click ->
Fence -> From Selection -> Fence -> Delete outside
8. Delete points within other breaklines to remove any remaining points that should not be considered in the creation
of the mesh -> Copy final breaklines to original or temporary working space in case altered/needed in future
8. Unify points reducing spacing to 1 foot to start and adjust settings for desired results.

CONTINUE TO…
Continue to Creating the Topographic Mesh
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This page will show you examples of sub-divided point clouds.
Hint: You can click on any image to see a larger version.

TOP VIEW
VI. Final Images from Example

Figure 16 â€“ Top view of the building with all of the vertical RPâ€™s visible; note the top-most RP (above
Piece_001) is the original vertical RP that was created from the wall/patch and defined the direction of the grid and
the division

SIDE VIEW

Figure 17 â€“ Side view of the building with the single horizontal RP that was used; note that this was the original,
default RP that was moved to a point on the floor of the main level.

SIDE VIEW

Figure 18 â€“ Side view of the building with all RPâ€™s visible; note that in terms of physical dimensions, the pieces
are not identical. The left side of the building is filled with complex layers of pipes â€“ this resulted in more points and
density. The RPâ€™s were placed close together making the physical dimensions of Piece_001 smaller than pieces to
the right. The right side of the building had larger, less complex equipment resulting in sparser points and density.
This meant that the physical dimensions of the pieces were larger although the size of the pieces (# of points) and the
size of the exports remained consistent. Finally, note the naming logic, the number indicates itâ€™s from left to right
and the letter A or B identifies whether it was the main level or basement level.

FRONT VIEW

Figure 19 (Left) â€“ Front view of a sectional cut and the horizontal RP used to divide the A & B cuts; Figure 20
(Right) â€“ Perspective view of the same piece; note that initially looking at the data, the lower section has smaller
physical dimensions and appears to be less complex/dense. However, the number of points and the size of the export
for the top section were approximately equal to the relative sizes of the bottom section. The bottom section was
extremely confined with many obstructions and a limited scanning range – resulting in very dense data on objects
close to the scanner. The top section was open and the occurrence of very dense data due to proximity to the scanner
was much lower. Here the scanning range itself resulted in the need for smaller pieces to achieve the appropriate file
sizes.
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This workflow will show you how to export your sub-divided point cloud.
Hint: You can click on any image to see a larger version.

CREATING PIECES AND EXPORTING DXF’S
V. Creating Pieces and Exporting DXFâ€™s â€“ Once the first two vertical RPâ€™s have been placed, the first
sectional piece will be copied into its own MS and exported.
A. In Piecing_Base, activate the top view (you may lock the rotation of the view to help create consistent fences
> Viewpoint > View Lock > Rotation)
B. Create a fence around the first area marked by RPâ€™s Vertical_001 and Vertical_002 > Copy fenced to
new MS
1. Leave a slight overlap beyond the RP to allow later re-assembly of the exports
2. Confirm that nothing is selected before creating the fence; otherwise the entire cloud will copy

Figure 11 â€“
Piece_001 is fenced and copied to a new MS, using the RPâ€™s as guides; note the fence overlaps slightly
beyond the RP, capturing redundant points between adjacent pieces for later re-assembly.

ACTIVATE SIDE OR FRONT VIEW
C. In the new MS > Activate a side or front view (you may need to unlock the view lock > Viewpoint > View
Lock)

Figure 12 â€“ Front view of Piece_001 in a new MS; note all vertical RPâ€™s are invisible, allowing the horizontal
division (the green line/RP in the center) to be clearly seen

Â

ACTIVATE RP DIALOGUE BOX
D. Activate RP dialogue box > Turn off the visibility of the vertical RPâ€™s > Turn on the visibility of the
horizontal RPâ€™s > You should now see the first piece of your data with RPâ€™s to dividing it into more pieces
(Suggested MS name Piece_001).

Figure 13 â€“ The top portion of Piece_001 is fenced and copied to a new MS; the green line in the center is RP
Horiz_001 showing the division between the two levels
Â

CREAT FENCE AND COPY TO NEW MS
E. Create a fence around the top piece > Copy fenced to new MS (Suggested MS name Piece 001_A) > Again,
remember to leave a slight overlap beyond the RP

Figure 14 â€“
Piece_001_A in its own MS, selected and being exported; note the overlap below the RP, creating some
redundancy between adjacent scans
Â

EXPORT
F. In new MS, select piece > Export > Confirm file type is DXF R12 (NOT 2D dxf â€“ currently DXF R12 is
the supported format for direct export from Cyclone) > Selected items > Export (Suggested export name
Piece_001_A)
NOTE: If Cyclone immediately states â€œ0 objects exportedâ€ either the file type is incorrect or the point cloud
was not selected before the export command. Check your settings and selection.
G. The number of points is displayed as the export begins. Roughly, when exporting, 1,000,000 points equals a
1 megabyte DXF. Noting this value at the beginning of each export helps you confirm that the resulting imports
will be manageable.
1. Even if you have evenly-sized pieces (based on physical measurements) the size of the data in the
pieces varies greatly depending on the complexity within each piece. 5 square meters of measured space
can have more points than 20 square meters of space depending on what is within that volume (ie: a
complicated network of pipes versus an empty room). Taking this into account and watching the
exporting figures are essential to figuring out how to divide up your specific project.
2. If the number of points is vastly smaller or larger than the desired file size, delete the MS for the piece
> adjust the RP > Copy out the new piece and try again!

CYCLONE BUGS?
3. Cyclone bugs?
i. When the point cloud piece is copied to its own MS, it may be selected and the object info

can be displayed. However, this info shows the number of points in the parent point cloud, not
the piece. When the export begins, appears to be the first time the accurate number of points in
the piece is displayed.

ii. When you name the export file, it always prompts that this file exists and asks if you want to
overwrite it; answer yes.

CLOSE EACH MODELSPACE
H. Close each MS > be sure to select CLOSE when prompted, DO NOT merge into the original MS or merge!!

I. Repeat Steps D through G for each vertical division of Piece_001, naming each export and MS/MS View as
you go (Piece_001_A, Piece_001_B, etc)

RENAME YOUR MODELSPACES
J. Before continuing, it is recommended that you go to Cyclone Navigator and rename each MS and each MS
view as shown in Figure 15 to avoid confusion. After Piece_001 is completely divided and exported, return to Step IV
-Section D and repeat the steps for dividing up the the next piece in the direction you are gridding (Piece_002)
reducing it to its sub-divisions (Piece_002_A, Piece_002_B, etc)

Figure 15 â€“ A closer view of the file structure in Cyclone Navigator; the MS for each vertical sectional slice is
named Piece_###. The MS and MS View for each horizontal piece (and the resulting .dxf exports) are named
Piecing_###_A , B, etc.
Â
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