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This page demonstrates how to create a data dictionary in Pathfinder Office, transfer it to a
GPS receiver, transfer data from the receiver to Pathfinder Office, differentially correct the

data, and export it for use in ArcGIS. 
Hint: You can click on any image to see a larger version.

 

 

Create Data Dictionary

A data dictionary makes GPS mapping easier by allowing you to predefine and organize point, line, and area
features and their associated attributes. The feature and attribute examples in this guide are used to
demonstrate how to use the Data Dictionary Editor in Pathfinder Office and to demonstrate the types of
parameters that can be set.

To begin, open Pathfinder Office and create a new project. Make sure that the outputs are going to your
preferred drive and file location. Click on “Utilities” located along the menu bar. Choose “Data Dictionary
Editor” and provide an appropriate title for your data dictionary. For the purposes of this guide, the name of
the data dictionary is “sample.”

Next, you may define the features to be included in the data dictionary. The features will belong to one of
the following feature classes: point, line, or area.

Point Feature

Create a point feature by selecting “New Feature.” The feature classification will be “point.” In this example,
the point features that we want to map are bus stops. So, the feature name will be “BusStops.”

Under the “Default Settings” tab, choose a logging interval of 1 second and set minimum positions to 120.
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The logging interval determines how often a GPS position is logged. Acquiring at least 120 positions per
point feature will ensure better accuracy (the positions are averaged to determine location). During data
collection, the receiver will give a warning message if you attempt to stop logging the feature before 120
positions have been recorded. When finished with the parameters on these tabs, press OK.

To set attribute information to be recorded with the mapped feature, select “New Attribute.” A window will
open allowing you to select the type of attribute you wish to define. In this example we would like to name
the bus route. Therefore the attribute type will be text. Choose “Text” and enter “RouteName” in the Name
field. Note that the Length field is important because the value specifies the number of characters that can
be entered when defining the attribute (be sure that the value is sufficient for the length needed). In the
New Attribute dialog box, there is an option to require field entry upon creation. Selecting this option will
ensure that you enter the attribute upon creation of the feature during data collection. Click OK to save the
attribute – you will see it appear in the Attributes window in the Data Dictionary Editor.

You may now define another attribute type. For example, we may wish to record how many people were at
the bus stop at the date and time that the feature was mapped. In this case, we want to select both “Date”
and “Time” from the New Attribute Type window. To record the number of people, a numeric attribute is
needed. After choosing “Numeric,” enter “# of people” in the name field. Note that a minimum and
maximum value should be set for the number of people possible (for example, a minimum of 0 and max of
50). You must also set a default number that is within the range of the minimum and maximum values. If
you do not update this attribute during data collection, the default value will be used.

Finish setting all of the desired attributes for the point feature and then close the New Attribute Type dialog
box before creating the next feature in the data dictionary.

Line Feature

Create a line feature by selecting “New Feature.” The feature classification will be “line.” In this example,
the line features that we want to map are sidewalks. So, the feature name will be “Sidewalks.”

Under the Default Settings tab, choose a logging interval of 5 seconds. Logging one position every 5
seconds should be sufficient when collecting a feature while walking. You may want to experiment with
different values here to test the accuracy of your results. When finished with the parameters on these tabs,
press OK.

To set attribute information to be recorded with the mapped feature, select “New Attribute.” A window will
open allowing you to select the type of attribute you wish to define. In this example we would like to
specify the type of material that the sidewalk is composed of (cement, asphalt, or unpaved). The easiest
way to record this attribute type is with a menu. Choose “Menu” and enter “Material” in the Name field.
Under “Menu Attribute Values,” press the “New…” button. Type “cement” in the Attribute Value field and
press “Add.” Cement will appear under “Menu Attribute Values” and the New Attribute Value – Menu Item
window will clear. Next type “asphalt” in the Attribute Value field and press “Add.” Finally “unpaved” may be
entered in the Attribute Value field. Press “Add” and then close the New Attribute Value – Menu Item
window. To require this attribute to be entered upon creation of the feature, select the “Required” option
under Field Entry. Selecting this option will ensure that you enter the attribute upon creation of the feature
during data collection.

Press OK to save the attribute before defining the next feature.

Area Feature

Create an area feature by selecting “New Feature.” The feature classification will be “area.” In this example,
the area features that we want to map are parking lots. So, the feature name will be “ParkingLot.” Under
the Default Settings tab, choose a logging interval of 5 seconds. Logging one position every 5 seconds
should be sufficient when collecting a feature while walking. You may want to experiment with different
values here to test the accuracy of your results. When finished with the parameters on these tabs, press



OK.

To set attribute information to be recorded with the mapped feature, select “New Attribute.” A window will
open allowing you to select the type of attribute you wish to define. In this example we would like to
record the number of handicapped parking spaces in the parking lot. To record the number of handicapped
parking spaces, a numeric attribute is needed. After choosing “Numeric,” enter “handicapped spaces” in the
name field. Note that a minimum and maximum value should be set for the possible number of
handicapped parking spaces(for example, a minimum of 0 and max of 20). You must also set a default
number that is within the range of the minimum and maximum values. If you do not update this attribute
during data collection, the default value will be used.

Finish setting all of the desired attributes for the area feature and then close the New Attribute Type dialog
box.

Save Data Dictionary

To save the data dictionary, choose “File” in the menu bar of the Data Dictionary Editor and select “Save
As.” Be sure to save the .ddf (data dictionary file) on your preferred drive and file location. The Data
Dictionary Editor may then be closed. You are now ready to transfer the data dictionary to the GPS receiver.

Transfer .ddf to GPS Receiver

Open either Active Sync (Windows XP) or Windows Mobile Devices (Windows 7) on the computer.  Turn on
the GPS receiver and then plug it into a USB port on the computer. It should automatically connect to the
computer. It is recommended to NOT sync the receiver with the computer.

Open Pathfinder Office (PFO) while the GPS receiver is connected to the computer. In PFO, go to Utilities >
Data Transfer > select the “Send” tab > select “Add” > Data Dictionary > the file defaults to the last .ddf
that was created (if not – browse to where the .ddf is located) > select the .ddf and click “Open.”

Under Files to Send, select the file by clicking it (it will become highlighted) > Transfer All

Once the data dictionary has been successfully transferred, you may close out of PFO.

You are now ready for data collection!

Transfer Data from Receiver to PFO

After data collection, transfer the data from the receiver to Pathfinder Office (PFO) by first connecting the
GPS receiver to the computer.  Open Pathfinder Office and then open the project.

Within PFO, choose Utilities > Data Transfer > Add > Data File. Select the files to transfer and choose
Open. Highlight the file(s) and choose Transfer all. Close the data transfer box once the file(s) successfully
transferred.

View your file by opening the Map (View > Map) and then choosing File > Open > and then selecting the
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file.

At this point, you may wish to improve the accuracy of the data through differentially correction.

Differential Correction

To differentially correct your features, complete the following steps:

Open the data in PFO > go to Utilities > Differential Correction > Next > Auto Carrier and Code Proc >
Next > Output Corrected and Uncorrected > Use smart auto filtering > Re-correct real-time positions > OK
> Next > Select your nearest Base Provider.

A report showing the accuracy of the results will be generated after differential correction has been
completed. The differentially corrected data may be exported for use in other programs including ArcGIS.

Export Data for use in ArcGIS

To export the data from PFO, select Utilities > Export. Be sure the Output Folder is set to where you want
the output file located (and be sure to remember the file path).

Export as Sample ESRI Shapefle Setup > OK.

Make sure that you are also exporting the uncorrected positions (select “Properties…” > select the “Position
Filter” tab > check the box next to “Uncorrected” under Include Positions that Are > OK). This will ensure
that positions that have not been corrected will also be exported.

Continue with the export even if no ESRI projection file has been found.

PFO can be closed once file has been successfully exported.

 

]]> http://gmv.cast.uark.edu/gps/13029/feed/ 0 http://gmv.cast.uark.edu/uncategorized/using-terrasync-
the-basics/ http://gmv.cast.uark.edu/uncategorized/using-terrasync-the-basics/#comments Tue, 12 Mar
2013 02:44:50 +0000 steph http://gmv.cast.uark.edu/?p=12917 Continue reading →]]>

This page will show you how to configure a GPS receiver with TerraSync and how to set and
navigate to waypoints. 

Hint: You can click on any image to see a larger version.

 

This guide is written for use with TerraSync v.5.41. The instructions vary only slightly for earlier versions of
the software. Reference the tab titled, Menu Hierarchy to become familiar with the terminology used in the
instructions.
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Menu Hierarchy

The TerraSync menu system hierarchy is as follows: sections, subsections, buttons, and fields (click on
image below). The information provided in the tabs throughout this series will utilize this terminology.

Start Terra Sync and Connect to GNSS

Turn on the receiver by pressing the power button. Start TerraSync by opening the Start menu and
selecting TerraSync from the menu options. In order to receive information from GNSS satellites, the GPS
unit must be connected to the GNSS receiver. To connect to the GNSS receiver, go to the Setup section.
Either expand the Options dropdown menu and choose “Connect to GNSS” or press the GNSS button in the
upper-right of the screen.

Configure GNSS Settings

There are a variety of ways to configure the receiver for data collection under the Setup section in
TerraSync. Open each of the six menus to verify that the parameters are set to the desired values. The
following are a few parameters to be aware of:
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Antenna Settings (under Logging Settings): If you are holding the receiver during data collection and not
using an external antenna, you may set the antenna height to 1 meter (which is approximately the height
of the receiver above the ground) and choose “Internal” under the Type dropdown menu. When using an
external antenna, set the antenna height to the height of the tripod (or whatever height the antenna will be
from the ground) and remember to choose the appropriate antenna from the Type dropdown menu.

Real-time Settings: Generally we set Choice 1 to Integrated SBAS, which provides corrections in real-time
when a SBAS satellite is available. Set Choice 2 to Use Uncorrected GNSS. If Wait for Real-time is selected,
only positions that have been differentially corrected will be used (meaning you may not be able to collect a
position unless the receiver is able to make a real-time correction).

Coordinate System: Typically we use Latitude/Longitude with the WGS 1984 datum. However, there may be
instances in which you will want to change the coordinate system.

Deleting Data

To delete data from the receiver, open the Data section and File Manager subsection. Expand the Choose
File Type dropdown menu to select the type of file to delete. Note: It is recommended not to delete Geoid
files unless necessary. Select the file you wish to delete by tapping on it (it will be highlighted in blue when
it is selected). Press the Options button and choose Delete.

Setting Waypoints

To set waypoints on the receiver, open the Navigate section and Waypoint subsection. Tap the New button
at the bottom of the screen (note: if a waypoint file is currently open, you must close it before creating a
new file – Options > Close File). Give the file a name (or leave the default name) and tap Done. Expand the
Options dropdown menu and choose New.
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If you have known coordinates to which you would like to navigate, you may manually enter the
coordinates. If you wish to mark a GPS position as a waypoint, expand the Create From dropdown menu
and choose GNSS. This option auto-fills the coordinates based on the current GPS position.

Navigating to a Waypoint

To use the receiver to navigate to an established waypoint, open the Navigate section and Waypoint
subsection. Select the waypoint you want to navigate to by tapping the box next to the waypoint (a check
will appear in the box). Expand the Options dropdown menu and select Set Nav Target.

Open the Navigate subsection. You should see the name of the waypoint listed at the top of the screen just
below the satellite icon. You are now ready to begin navigating. You must start moving in order for the
receiver to become oriented in space and give you directions. It doesn’t matter which direction, just start
moving. You may adjust the navigation settings by expanding the Options dropdown menu and selecting
Navigation Options.

After reaching a waypoint, you may expand the Options dropdown menu while in the Navigate subsection
and choose Goto Next Unvisited Waypoint. Alternatively, you may clear the waypoint by opening the
Waypoints subsection, expanding the Options dropdown menu and selecting Clear Nav Target. You may
then set your next navigation target.
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