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This series will show you how create a mesh and model surface topography in Leica’s
Cyclone
Hint: You can click on any image to see a larger version.

INTRODUCTION AND DEFINITIONS

In this guide, a mesh is considered to be a series of triangles that represents a surface. Cyclone generates
meshes by using the points in a point cloud, vertices, polylines, or any combination of the three as vertices.
For each adjacent trio of points in a cloud, a triangle is created. This has the effect of creating a visually
coherent surface from the point cloud, and it is the primary method for modeling topography.

Break lines are lines or polylines that sub-divide the mesh; they represent the edges of a paved surface, a
ridge, a channel, or any other topographic feature that the user wants to preserve.  While mentioned in 2D
topographic tracing, break lines become very important in meshing.  Here, they have an accurate z-
coordinate and they become the edges that the triangles in the mesh conform to, defining and controlling
the smoothness and continuity of the mesh. They allow the user to break-up the mesh into reasonable
“chunks” for future texturing and detailing.

Please see ‘Leica Cyclone – Creating a Basic CAD Ojects From Surface Topography (2D)’ as a supplement to
this workflow.

OPEN A REGISTERED UNIFIED MODEL SPACE

1. Open a Registered Unified Model Space -> Create fence around ground plane –> Right Click –>
Copy Fenced to new Model Space (NOTE: viewing from a standard side, front, or back view in orthographic
mode assists in selection) -> Original MS may be closed

Figure 1 – (Left) Original registered scan world of plaza (Right) Point Cloud Sub-Selection (Select -> Right
Click -> Point Cloud Sub-Selection) allows unneeded points, such as trees and vertical surfaces, to be
deleted; Sub-selection allows the user to precisely choose and view points before deciding to delete

SELECT AND DELETE UNNEEDED POINTS
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2. In the new Working MS -> Select and delete unneeded points (it’s best to eliminate as much
vertical surface data as possible so that the ground plane to be modeled is isolated; objects in motion, such
as trees/vegetation can be especially problematic and cleaning up areas where these are abundant is
suggested; eliminating data that may be present inside buildings or areas that will not be modeled is also
suggested)

Figure 2 – The same plaza as Figure 1 now copied to a working MS and “cleaned” of unneeded vertical
surfaces and vegetation leaving only the ground plane to be modeled.

CREATE NEW LAYERS FOR THE BREAKLINES AND FEATURES

3. Create new layers for the breaklines and features (Shift + L) -> Review the area to be modeled
identifying where the surface changes and/or where the user wants a clean break or difference between
adjacent surfaces.Create layers for primary and secondary features as needed.

4. Create lines to represent the topography and features, assigning an accurate x, y, and z
coordinate -> There are several ways to make lines including (1) using 2D drawing methods (covered in
‘Topography and Site Elements – 2D’ above) (2) with pick points, (3) by extending an existing line (4) by
snapping two existing lines together (5) by creating a polyline with Fit Edge command, and (6) by merging
polylines together.

See Help -> Contents -> Search -> ‘Make Lines, Polylines, and Breaklines’ for steps for each of these
methods.There are additional variations of each.BEWARE: Lines created by pick points cannot be used
for break lines in meshing; if picking points, be sure to create a polyline rather than a line segment.

TIPS

5. Tips

A.  If drawn in 2D, use Edit Object -> Move/Rotate to move the object to the correct z-coordinate;
there are multiple options moving objects including by a standard axis and pick points.

B.  Create additional break lines following the feature or edge of the break lines; place these to
break up the mesh and around the boundaries, segmenting out areas where a topographic ground
plane is not needed (ie: inside buildings)
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Figure 3 – Top view of plaza; Polylines have been created to outline where the sidewalk and grass meet; orange handles help highlight
the polylines

MORE TIPS

More Tips:

C.  Use multiple views to confirm line is properly located at all angles and handle constraints (Edit
Object -> Handles constrain to -> Various options – NOTE: once placed in top view, constraining
handles to z-direction helps placement in 3D)

D. Try different methods to see what works for you.With all, use multiple views to confirm the line
is properly located at all angles

Figure 4 – (Left) Although from Top View, the breakline looks correct, inspection from a different angle reveals that it is not correct (Right)
Handles and constraints (Edit Object -> Handles -> Constrain Motion) are used to pull the polyline into the correct position – every section of
every breakline should be inspected from multiple views

FINAL STEPS
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6. Create handles at places where polylines intersect (Select line -> ALT + Select point on line for
new handle to help snap lines together).

7. Delete all points beyond boundary of mesh -> Select polyline representing boudary of mesh ->
Right click -> Fence -> From Selection -> Fence -> Delete outside

8. Delete points within other breaklines to remove any remaining points that should not be
considered in the creation of the mesh -> Copy final breaklines to original or temporary working space in
case altered/needed in future

8. Unify points reducing spacing to 1 foot to start and adjust settings for desired results.

CONTINUE TO…

Continue to Creating the Topographic Mesh
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This workflow will show you how to model non-rectangular patches in Leica’s Cyclone. 
Hint: You can click on any image to see a larger version.

 

THE 2D DRAWING TOOLBAR

Modeling a Non-Rectangular Patch

Quick Discussion on 2D Drawing and Reference Planes

To create a non-rectangular patch, you use the tools on the 2D drawing toolbar. If the drawing toolbar is
not enabled, RC anywhere in the Toolbar area and add the Drawing toolbar. As a good rule of thumb, I
always dock it on the right side of the screen.

IMPORTANT: All 2D drawings in Cyclone are constrained to a base plane. To view the active reference
plane, go to Tools –> Reference Plane –> Show Active Plane. All cyclone projects come with a default XY
plane (Z normal) – shown to the below.
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 Figure 12: The base XY plane in all Cyclone projects.

You can add numerous reference planes to a project Tools –> Reference Plane –> Add/Edit . You can
also move reference planes and assign them to selected objects Select Object -> RC -> Set on Object.
If you are not working in a specific coordinate system, it is easiest just to move the active reference plane
to the object that you are trying to model.

MODEL A NON-RECTANGULAR PATCH

Model a Non Rectangular Patch
To model a non-rectangular patch such as a unique outline of a wall, first fence and create a small patch
on the wall. Next, go to Tools –> Reference Plane –> Set on Object to align the reference plane along the
same direction as the newly created patch. Select the patch, select ViewPoint –> Align to Selection, this
constrains the view to be directly perpendicular to the patch. At this point, it is important not to rotate the
view, if necessary choose View –> View Lock –> Rotate.

 Figure 13: (Left)
Drawing a small patch along a section of wall and (Right) Aligning the base reference plane to that patch in

order to use the 2D drawing tools

Note: viewing orthogonally or perspectively affects visibility and clarity of features; toggle between views with hot
key ‘o’.

Figure 14: Mode Toolbar shows
whether current view is orthogonal or perspective

Next choose the appropriate 2D drawing tool, in this case Draw Polygon tool ->Trace the feature of
interest -> Accept/Create the drawing by either clicking the green check button at the top of
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the Drawing Toolbar or RC -> Create. The 2D sketch should turn bright green with orange handle at
the intersections. Edit the sketch as needed. Next to create a patch from the 2D sketch, select the sketch
-> Create Object –> From Curves –> Patch.

Figure 15: (Left) 2D
Curve sketched on building feature profile (Right) Patch fit to the curve

You have Finished!

You have finished the Leica Cyclone 7.0: Introduction to Modeling workflow!
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This workflow will show you how to edit, extend, and extrude patches in Leica’s Cyclone. 
Hint: You can click on any image to see a larger version.

 

Modeling – Editing, Extending, and Extruding Patches:

MAKE RECTANGULAR

Make Rectangular: When patches are created, they have multiple edges and vertices. It is a good rule of
thumb, to make all patches rectangular before editing them. To make patches rectangular, Multi-select
all patches –> Edit Object –> Patch –> Make Rectangular

 Figure 7: Patches that have been made rectangular

1. Note: When made rectangular, patches will sometimes extend beyond the surface being modeled;
use the handles to drag the corners/edges so that they are completely within the area of the
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surface being modeled 

 Figure 8
(Left) Surface to apply patch to is highlighted in yellow; (Center) Patch created and made rectangular
– note the corners extend beyond the surface being modeled; (Right) Using the handles, the patch

has been dragged so that it is completely within the surface being modeled

EXTENDING PATCHES

Extending Patches:

Extending patches extends the boundary of the selected patches to intersect together. There are several
options to do this.
Note: The order in which the patches are extended and the number of patches being extended in a single
command affects the calculations that Cyclone makes. Adjusting the order and number of patches involved
may create different results depending on the complexity of the geometry.

To extend all patches to one another –> Multi-select the patches to extend –> Edit Object –>
Extend All Objects.
To extend patches to a single patch –> Multi-select (1) patches to extend (2) the patch which
the others are to extend to –> Edit Object –> Extend to Last Selection (Note, you may also
extend to a reference plane with this command or Select Object -> RC -> Extend to Reference
Plane)
Next: Continue extending the objects to their perimeters (ie wall boundaries) and using handles to snap
adjacent objects/patches together

SLICING PATCHES

Slicing Patches:

As objects/patches are extended, they may extend beyond the plane or object specified. Patches may be
sliced by adjacent patches to clean up corners
Multi-Select Patches to Slice -> Create Object -> Slice -> By All in Selection (every patch
selected is sliced where it intersects with every other patch) / By Last Selection (Every patch selected is
sliced where it intersects with the last object selected) / By Reference Plane (Every patch selected is
sliced by specified Reference Plane)
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 Figure 9: (Left) Extended patch has extended beyond the
referenced object (single patch makes up area inside yellow triangle) (Right) Patch has been sliced so that

it is now divided into two patches where it intersects the reference object (sub-divided patch now
highlighted with yellow triangle

 Figure 10: Sub-divided patches can now be deleted, leaving clean corners
where patches intersect

EXTRUDING PATCHES

Extruding Patches:
Create the patch –> multi select 1) the patch and 2) a point on the point cloud or another
object that you would like to extrude the patch to.

 Figure 11 (Left)
Creating a rectangular patch then multi-selecting the patch (1) and a point on the wall (2) to extrude it to

(Right) The resulting extrusion

CONTINUE TO…

Continue to Leica Cyclone 7.0: Modeling Non-Rectangular Patches.
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This workflow will show you how to begin modeling in Leica’s Cyclone. 
Hint: You can click on any image to see a larger version.

 

GETTING STARTED

Getting Started

1. Cyclone Navigator –> Project –> Model Space -> Open/Copy/Delete Model Spaces here
2. Draw a fence to select the area to be modeled. The fence tools are located in the ‘Mode’ toolbar next

to the navigation tools. Once the points are “fenced”, copy them into a new Working Model Space
(Select –> Right Click –> Copy Fenced to new Model Space)

 Figure 3: Fence Tools

3. Unify or Merge the clouds in the new MS (See Temporary Model Spaces Above)

MODELING A FLAT SURFACE: METHOD 1

Modeling – Creating a patch to represent a wall or flat surface:

Method 1 – Fit to Cloud (More conservative): 

1. Draw a fence across flat surface using appropriate fence tool. 
2. Once the fence has been drawn, RC, select Point Cloud SubSelection – Add Inside Fence.

1. Next, make sure there are no points BEHIND the flat surface that accidentally got selected. If
there are, draw another fence around them, RC – Point Cloud SubSelection – Remove Inside
Fence (may have to repeat multipe times)Once you have the flat surface properly selected,
select Create Object –> Fit to Cloud –> Patch .

 Figure 4: (Left)
Selecting points in a dataset (Right) Rotating the dataset and removing the points that were erroneously

selected behind or “through” the data
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METHOD 2

Method 2 – Fit to Fenced:

1. Draw a fence across flat surface using appropriate fence tool (making sure to not select
any points behind the flat surface). RC –> Select Fit Fenced –> Patch.

 Figure 5: Process of drawing a fence on a flat
surface then simply right clicking and selecting Fit Fenced – Patch

METHOD 3

Method 3 – Region Grow (Relies on Cyclone and placed parameters to decide how patch forms)

1. Select a point that is at the center of the area or surface to patch (Selection Tool ->
Left Click); Note: the Region Grow command evaluates the points in a radius from the
point selected

1. Create Object –> Region Grow –> Patch
1. The Region Grow Dialogue Box allows the user to adjust the number of points that

Cyclone uses to calculate the surface of the patch

Region Thickness – thickness/depth of point cloud data used for region;
lowering this number increases accuracy; be aware of changes in the depth of
surface materials such as the mortar between bricks when adjusting this number.
Maximum Gap to Span – maximum hole or shadow in cloud point data to
“jump” and continue calculating the region
Angle Tolerance – used for meshes only
Region Size – the diameter radiating from the central pick point to calculate the
region



 Figure 6: (Left)
Region Grow with maximum region size – the white points represent the proposed patch. (Right) Reducing
the region size so that fewer points are considered for the proposed patch – note the radial pattern with

the first selected point at the center.

CONTINUE TO…

Continue to Leica Cyclone 7.0: Modeling – Editing, Extending, and Extruding Patches
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This workflow will show you how to create basic geometries and trace topography in Leica’s
Cyclone software. 
Hint: You can click on any image to see a larger version.

DEFINITIONS

Definitions: Vector Objects are geometrical primitives, such as lines, curves, and polygons, that can be
used to represent a surface or feature. These geometries can be 3D or 2D, depending on how they are
created. These objects can be exported and used as two dimensional drawings (for site plans or printed
documentation) or as three dimensional objects (in CAD or GIS software). Creating lines two dimensionally
through tracing, is highly dependent on the user’s interpretation and basically comes down to visually

Definitions: Break lines are lines or polylines that sub-divide topography into reasonably sized sections;
they represent the edges of a paved surface, a ridge, a channel, or any other topographic feature that the
user wants to preserve. In vector drawings, break lines consist of lines, curves, and splines. In meshes,
break lines become the edges that the triangles in the mesh conform to, defining and controlling the
smoothness and continuity of the mesh. Whether creating a vector drawing or a mesh, tracing the break
lines and other lines making up the site is one of the first steps.

Workflow for Tracing Topography and Site Elements – 2D: Please see ‘Lecia Cyclone: Interface
Basics’ and ‘Beginner’ and ‘Advanced Workflows for Building Modeling’ for an introduction and an overview
of topics not covered here.

OPEN A REGISTERED UNIFIED MODEL SPACE

I. Open a Registered Unified Model Space -> Create fence around ground plane –> Right Click –>
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Copy Fenced to new Model Space (NOTE: viewing from a standard side, front, or back view in orthographic
mode assists in selection) -> Original MS may be closed

Figure 1 – (Left) Original registered scan world of plaza (Right) Point Cloud Sub-Selection (Select -> Right
Click -> Point Cloud Sub-Selection) allows unneeded points, such as trees and vertical surfaces, to be
deleted; Sub-selection allows the user to precisely choose and view points before deciding to delete

 

SELECT AND DELETE UNNEEDED POINTS

II. In the new Working MS -> -> Select and delete unneeded points: it’s best to eliminate as much
vertical surface data as possible so that the ground plane to be modeled is isolated. While tracing, deleting
unneeded data is primarily used to clarify details being traced; it becomes more important when meshing.

Figure 2 – The same plaza as Figure 1 now copied to a working MS and “cleaned” of unneeded vertical
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surfaces and vegetation leaving only the ground plane to be modeled

 

III. Identify break lines and level of detail -> Create a new layer for the break lines (Access Layer
Manager by Shift + L) and make this layer current (Highlight layer & click ‘Set Current’) -> Review the area
to be modeled and identify areas where the surface changes and/or where you want a clean break or
difference between adjacent surfaces. We will create lines in these areas. Create layers for primary and
secondary features as needed depending on the complexity of site.

SHOW THE ACTIVE REFERENCE PLANE

IV. Show the Active Reference Plane. In Cyclone, when using 2D Drawing Mode, the Active Reference
Plane plane becomes the location along which all drawn objects are located. For example, in Top View,
which we will be using, all objects have their z-coordinates on this plan. It is comparable to the piece of
paper upon which a site is drawn by conventional methods.

NOTE: Commands are based on the active reference plane. There is always a plane active
whether it is visible or not. Planes can be activated and edited in the RP Manager (Tools > RP >
Add/Edit)

NOTE: Creating and placing 3D polylines/curves with an accurate z-coordinate is covered in the
document ‘Leica Cyclone – Creating a Mesh and Modeling Surface Topography 3D’.

SHOW THE ACTIVE REFERENCE PLANE 2

V. In general, we will trace along the edges of features, either where a feature meets the ground plane or
where the ground plane changes. -> To place Reference Plane:

A. Tools –> Reference Plane –>Set to Viewpoint ; this aligns the reference plane to the Top
view. If you notice in the next image, the plane passes right through the middle of the site.

B. Move the plane to the base of the site -> Select a point at the lowest significant point on
the site -> Tools –> reference Plane –> Set plane origin at pick point. This translates the plane
down to the site base.

SELECT TOP VIEW

VI. Select Top View -> All tracing will be done in top view; it is important not to rotate the view, if
necessary choose View –> View Lock –> Rotate

VII. Select Orthogonal View -> Hot key ‘O’ (hot key toggles between orthogonal and perspective



Figure 3 – (Left) Setting the Reference Plane to align with the Top-down Viewpoint (Right) Moving the
Reference Plane down to the lowest point on the site

 

TRACE SITE FEATURES W/ 2D DRAWING MODE

VIII. Use 2D Drawing Mode to trace site features -> Select a drawing tool -> ->Trace the feature of
interest -> Accept/Create the drawing by either clicking the green check button at the top of the Drawing
Toolbar or RC -> Create. The 2D sketch should turn bright green with orange handle at the intersections.
Edit the line/sketch as needed (see editing some editing options in following steps).

Figure 4 – (Left) Top view: two polylines (highlighted with orange handles) trace an upper stair and a lower
stair. (Right) Perspective view showing that the stairs are located at different heights (different z-

coordinates).
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Figure 5 – A side view shows that the polylines representing the edges of the 2 stairs (in orange) are
located at a single height/z-coordinate along the active reference plane (in green).

TRACING TIPS

Tips – Object Types: Lines and polylines are open objects (with a beginning and an end); polygons are
closed objects (with an area and a perimeter); curves can be created through picking a variety of points.
Polylines are usually the best tool for fairly straight features. In general, it is best to have one polyline than
multiple individual lines representing a feature. Any feature that you ultimately plan to extrude or model 3-
dimensionally should be a closed object.

Tips: Use the Modes Toolbar  to navigate within the space
while drawing mode is active; while drawing, LC the hand icon to pan and LC the pencil icon to return to
the current line/arc. Also use the Modes Toolbar to toggle between orthogonal and perspective views.

Tips – Accuracy: The level of detail/accuracy depend on many things including the ultimate needs, user
interpretation, level of zoom and point width while drawing. It is recommended to choose and use a
consistent method (same level of zoom, same point width) for similarly sized features to improve the
chances of multiple users creating similar results in an area. With irregular features, often using a polyline
with many vertices represents a curve more accurately than geometrically correct arcs.

SNAP LINES AND POLYLINES TOGETHER

IX. Snap ends of lines or polylines together -> Multi-pick two line (or polyline) segments to snap
together -> With multi-pick, click and hold the handle of one of the lines -> Hold Shift while dragging the
line toward the handle of the 2nd line until they snap together -> These lines are not joined, they remain
separate entities
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Figure 6 – (Left) The base of a column has been traced with a polyline and a line; (Middle) The point
cloud’s visibility is turned off showing the two independent objects; (Right) The ends of the 2 objects have

been snapped together but they remain as independent entities

MERGE LINES OR POLYLINES TOGETHER

X. Merge lines or polylines together -> With multi-pick mode, pick each of the lines to be merged ->
Create Object -> Merge -> Multiple objects now become a single object -> Snapping the end handles
together and merging creates closed objects.

NOTE: Only similar objects can be merged (i.e.: lines to lines, polylines to polylines); In some
cases polylines disappear due to the order the polylines were selected; If the line disappears after
merging, undo, and reverse the order the lines are selected

NOTE: Toggling the visibility of points and objects (Property Manager > Shift + L), and adjusting
the visibility of the Reference Plane (Tools > RP > Add/Edit), can help clarify what you are drawing.

XI. Extend a line -> Pick line (with pick mode NOT multi-pick) -> Pick the end handle, hold and drag (line
will extend in same 3D direction as original line) OR Pick the line, multi-pick a point in the point cloud that
you want to extend the line to -> Edit Object -> Extend to last selection (the line will extend in the
direction it was originally created)

EXPORTING

XII. Exporting: There are several options for exporting topographic features. The objects created through
tracing can be exported or the point cloud itself can be exported.

A. Export the lines, polylines, arcs -> Use the properties manager (Shift + L) to turn off the
visibility/selectability of the point cloud -> Select All -> File -> Export

2D DXF R12 Format – all objects export on a single 2-dimensional plane (in this case the
active RP) – use this setting for 2D applications
DXF R12 Format – 3D information is retained (in this case the z-coordinate for the lines) –
use this setting if the objects have different z coordinates
Objects may also be exported as ASCII or XML file types here
Once exported, the .dxf file can be opened in CAD, imported into Sketchup, or converted
for multiple software.

B. Newer versions of AutoCAD (2009 and beyond) support point clouds. If you do not have
Cyclone but you do have CAD, use Cyclone to export the points and then trace/model in CAD software
much as we have done in Cyclone. The main issue is file size; in general, point clouds must be broken
into smaller pieces to allow them to be imported into CAD software. See the CAST workflow, ‘Reducing
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Point Clouds for Autodesk Applications’ for more details.

NOTE: In general, export .PTS file types with a maximum size of 4mb to import into CAD as of 2011
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This series will show you advanced modeling building modeling techniques using Leica’s
Cyclone.
Hint: You can click on any image to see a larger version.

COPY TO NEW MODELSPACE

In addition to modeling individual building walls, you also have the ability to trace the footprint of a building
and extrude it up.

I. First, copy/subset the building into its own working ModelSpace > Draw a fence around the
building > RC > Copy to MS

II. Next, show the Active Reference Plane. Depending on what you were working on last, the
reference plane will probably be in a different location. Because we are tracing along the base of the
building, we can use the standard top down view as a basis for creating our footprint sketch.

1. View –> Standard Views -> Top.

2. Select Tools –> Reference Plane –>Set to Viewpoint ; this aligns the reference plane to the
Top view.  Note in Figure 1, the plane passes right through the middle of the building. In order to place
the plane at the bottom of the building (so that our footprint sketch is placed along the building base),
select a point at the very bottom of the building and then select Tools –> reference Plane –> Set
plane origin at pick point. This translates the plane down to the building base.

Figure 1 (Left) Setting the Reference Plane to align with the Top-down Viewpoint (Right) Moving the
Reference Plane down to the building base

SELECT VIEW AND TRACE THE BUILDING

III. Select View –> Top DO NOT ROTATE THE VIEW (if necessary, choose View – View Lock – Rotate to
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constrain the view) > IMPORTANT:Change the View from Perspective to ORTHAGONAL (hot key ‘o’).

IV. Trace the building footprint using a series of polylines/curves (splines). Make sure you snap all of
the handles together so that the curves create a closed object.

Figure 2 (Left) View constrained to top-down/orthogonal (Right) Series of curves drawn around the base of
the building

SELECT AND EXTRUDE

V. Multi-select all of the curves -> Create Object –> From Curves –> Patch. If necessary, add
additional handles to patch and modify as necessary.

Figure 3: (Left) Patch created from series of curves representing the base of the building (Right) Patch
extruded up to approximate shape of entire building

VI. Extrude the patch -> Multi pick 1st) the patch and then 2nd) a single point on the roof of the
builidng -> Edit Object –> Extrude –> Extrude to Last Pick. The patch should then be extruded up to the
roof height and all of the walls should be accurately modeled.

MERGE MODELSPACE INTO ORIGINAL

VII. Finally, close the ModelSpace and to merge the modeled results back into the original project
> select Merge into Original ModelSpace and Delete after Close (if desired) > Option to merge appears
once the close command is selected
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Figure 4 Close ModelSpace and merge modeling results back into original ModelSpace

CONTINUE TO…

Continue to Modeling Openings in Objects
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This document will give a brief description of modeling and the modeling tools used in
Leica’s Cyclone software.. 
Hint: You can click on any image to see a larger version.

 What is Modeling: The process of creating CAD (Computer-Aided Design) objects. In Cyclone, models
are based on 3D point cloud data. CAD models involve more than only shapes as they can also convey
information, such as materials, processes, dimensions, and other user-specific details.

To model in Cyclone, you must use:

LAYERS

Layers (Shift+L): Layers are used to group similar objects together. This is useful for LOD modeling,
controlling object visibility, selectability, etc… ALWAYS model in a layer(s) separate from your original point
cloud.
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Figure 1: Use the Shift+L button to open the Layers Dialog. Here you can create new layers, set the current
layer, and select and assign objects to layers.

FENCES

Fences: A fence is a 2-dimensional rectangle or polygon that is used as a boundary to select/deselect
objects, point clouds, etc…Note: Utilizing the Tool Bar for selection and toggling between modes
will make this much easier rather than navigating through the pull down menus: (Right Click in any part
of the menu bar section to pull down the selection list –> Check the Modes selection –> Dock it
somewhere on your screen by clicking and dragging). Beware that toolbars “hide” or dock behind others
and tend to drift off of the screen. If you can’t locate a toolbar that is listed as showing, drag toolbars to
look behind them.

  Figure 2: Accessing
Toolbars in Cyclone

TEMPORARY MODEL SPACES

Temporary or “Working” Model Spaces (Select –> RC –> “Copy Fenced to New ModelSpace”) :
Copying specific areas into temporary or smaller model spaces while modeling allows the user to focus on
the pertinent data, making navigation and file handling faster and more efficient. It also allows the user to
experiment without threatening the integrity of the original, complete model world. As long as the
coordinate system has not been altered, the user can copy/paste (CTRL + C and CTRL + V or Edit –>
Copy/Paste) between ModelSpaces and data will transfer in its correct location.

Note: When closing the new “working” model space, the user has the option to “Merge into Original
MS” (EVERYthing re-imports, points, objects, etc); “Remove Link from Original MS” (the “working”
MS will be saved but will not be associated with the original); or “Delete after close” (the MS and all



work in it will be removed). If this dialogue box is closed without a selection, the temporary
ModelSpace will be saved in the project with a default name assigned.

Beware: Cyclone does not use a SAVE command; instead, every action is saved, with the option to
UNDO, as the user works. It is imortant to pay attention to how model spaces are closed and saved
while adjusting to this.

Beware: Cyclone allows multiple ModelSpaces to have the same name leading to confusion if note
accounted for.

MERGING/UNIFYING POINT CLOUDS

Unifying or Merging Multiple Point Clouds: When working with large data sets, it is also recommended
to combine the copied point clouds in the working ModelSpace for further ease in navigation and file
handling. There are 2 choices for this:

Unify
(Selection –> Select All –> Tools –> Unify Point Clouds) : All point clouds are now
considered as single cloud in the new “working” model space; note that some functions of the scan
world are not maintained with this command.

Merge (Selection –> Select All –> Create Object –> Merge):  All point clouds are now
considered as single cloud in the new “working” model space; all functions of the scan world are
maintained with this command.

CONSTRAINTS

Constraints: There are constraints, handles, and snapping functions that aid in the modeling process.
Constraints are parameters that the user sets within Cyclone that limit movement, rotation, and drawing
tools to specific planes or axes. These parameters regularize and orthagonalize the modeling process.
Constraints can be set before the object is created to model more strictly or they can be used with object
handles after the obejct is created to manipulate it.

Before Creation: Align the view of the point cloud to the best vantage point of the intended
object’s geometry. Viewpoint –> View Lock –> Rotation  locks the user’s view to this viewpoint.

Before Creation: Edit Object –> Snapping Grid –> Set Spacing, Rotation, Set to Snap :
User can set the spacing of the grid and the rotation to snap to this grid; user can toggle this snap
on/off as needed.

During Creation: Tools –> Drawing –> Align Vertices to Axes : toggles on/off the restriction
of each vertex to be on the same x or y axes as the previously plotted vertex; after drawing the 1st
vertex, the next vertex snaps to the same x or y axis (whichever is closer) as the previous vertex;
you may also set the distance to the next vertex here.

HANDLES

Handles: After creation, objects have a variety of number of handles depending on their geometry. These
handles are locations the user can click to grip the object and snap them to manipulate the object’s shape,
size, location, and/or rotation. To resize or re-shape
an object –> simply grab and move one of the orange handles located on its perimeter. The blue handle
(in the center) is often used to completely translate or move the patch. To add/delete handles –> hold
the Alt key when selecting on the handle. Conversely, to add a handle –>  hold the Alt key and select
along the patch edge.

Handles: Constraints to the Model Space



Edit Object –> Handles –> Show, Constrain Motion, etc…

Edit Object –> Handles –> Edit Snap to Object Threshold : this sets the proximity for snapping
handles to objects

Handles: Constraints to Current ActionConstrain handle to specific axis: Select the handle

–> press the x, y, z key
1 time –> handle constrained on this axis

–> press x, y, z key 2nd time –> handle constrained to plane that does not contain that axis

–> press x, y, z key 3rd time –> removes constraint

SNAPPING

Snapping: Snapping allows the user to snap an object’s handle to another object’s handle or to a grid, the
spacing of which can be set by the user Edit Object –> Snapping Grid –> Set Spacing .

Snapping Patch Handles: To snap the handles of two adjoining patches together, first select the
patch that you are going to SNAP TO then hold the Shift key – grab the handle on the other patch
and move it towards the handle that you are snapping to – the two handles should snap together.

OBJECTS, PATCHES & PRIMITIVES

Objects: There are multiple ways to create objects and meshes. The way that objects are created and the
constraints used rely on the user to interpret the scan data and the desired results. This modeling process
ranges from precise models that accurately represent the point cloud to highly orthagonal models that less
accurately represent the point cloud data but provide more regularized geometries.

Patches: A patch is a plane surface generated from a minimum of 3 points that represents a flat surface
that fits to the point cloud. Patches can be extended and grouped to form more complex objects. There are
several methods for creating patches.

Primitives (Create Object –> Fit to Cloud or Fit Fenced) : Primitive shapes such as cylinders, boxes,
and spheres can be fit to point clouds. These objects impose orthagonalized geometry into the modeling
process. 
Steel Sections/Tables (Create Object –> Fit to Cloud or Fit Fenced): Cyclone allows the user to fit
standardized steel sections to the point cloud data to aid in the construction of bridges and any other
structures that utilize steel components. After insertion, these sections can be slightly adjusted/customized
within a table. Again, these objects/sections impose standardized geometries into the modeling process.

Beware: When an object is created, the object replaces the points that it represents. It is useful to
replace or reference these points if more detail or comparisons are needed (this must be done immediately
after object is created as the capability is eliminated as modeling progresses)

Select Object –> Right Click –> Insert Copy of Object’s Points or Show Object’s Cloud

CONTINUE TO…

Continue to Leica Cyclone 7.0: Modeling a Flat Surface …
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